3

I installed Mojave on VMWare. Below are the details.

enter image description here

I downloaded and installed xcode 9 and it was not compatible with this mojave version. How can I get to know about the correct version of xcode for mojave 10.14.4?

5
  • 1
    Don't you just open the App Store app and click install to get Xcode now? (Although with that serial number, this might not be running macOS on Apple hardware directly) – bmike May 24 '20 at 12:45
  • i.stack.imgur.com/Td7fA.png @bmike that's what I see on mine. So before downloading it from apple website, I need to know which one I need. – anki May 25 '20 at 6:14
  • Ahh yes - so once you purchase an app, you should be able to download older builds but if you are about to “buy” it for the first time, you have to meet the current requirements to start the download. So - maybe try to buy it from Catalina mac or VM and then go back to the Mojave mac and see if the purchase history lets you download an older build for that OS? – bmike May 25 '20 at 16:24
  • @bmike I had bought Xcode in the past, then deleted it. Downloaded it via web recently. For iMovie, I bought it, deleted it, and I can no longer get a working iMovie version for myself form anywhere. // I cannot test your hypothesis either though. Simply don't have enough bandwidth atm – anki May 25 '20 at 16:39
  • I don’t have an 10.14.4 mac to test either. I do have access to developer.apple.com/download/more so I could test with some time if I really needed to know a specific combination – bmike May 25 '20 at 16:46
7

For macOS 10.14.4, Xcode versions compatible are: Xcode 10.2 - 11.3.1.

Xcode 11.4 onwards requires macOS Catalina, 10.15.2

With a free Apple Developer account, one can download older versions of Xcode (all the way back to Xcode 2.3 as well as new as 11.5 at https://developer.apple.com/download/more/

Also a nice catalogue: https://xcodereleases.com/

7
  • @TomHarrington if you could add some insight.. I'm still doubtful about min version for 10.14.4 being 10.2. In fact there's nothing stopping one from using 10.1 either on it. But ofc I can defend it saying that the up-to-date the better & then 10.3.1 is the limit. – anki May 25 '20 at 16:44
  • As I read it, the site gives the minimum version of macOS to use a specific version of Xcode, but the reverse isn't true. I would expect to be able to run older versions of Xcode, for a while at least, so Xcode 10.1 almost certainly runs on macOS 10.4.4. – Tom Harrington May 25 '20 at 17:46
  • Does it mean that x-code version 11.3.1 is also compatible with Mojave 10.14.4? – Pankaj Jun 2 '20 at 17:45
  • @Pankaj yes. 10.3.1 requires minimum 10.14.4. so yes. – anki Jun 2 '20 at 18:46
  • @anki - is it really an iCloud account - I have two apple accounts and the non iCloud one is the one I have to use for downloading Xcode (the account was originally an Apple Developer account) – mmmmmm Mar 21 at 10:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .