6

I installed Mojave on VMWare. Below are the details.

enter image description here

I downloaded and installed xcode 9 and it was not compatible with this mojave version. How can I get to know about the correct version of xcode for mojave 10.14.4?

1
  • Note - any question on Xcode versions ages out to “ancient history” territory quickly. We can list what a specific combination do, but there are apps to manage all the versions and this quickly becomes a “dev code maintainance” subjective question IMO.
    – bmike
    May 1, 2021 at 13:21

1 Answer 1

11

For macOS 10.14.4, Xcode versions compatible are: Xcode 10.2 - 11.3.1.

Xcode 11.4 onwards requires macOS Catalina, 10.15.2

With a free Apple Developer account, one can download older versions of Xcode (all the way back to Xcode 2.3 as well as new as 11.5 at https://developer.apple.com/download/more/

Also a nice catalogue: https://xcodereleases.com/

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .