6

Over the past few months, I have experienced my MacBook turning on its fans because of high CPU usage. When that happens, I see that a process called remindd is using 100-300% CPU for a long time, usually more than 10 minutes. It seems this process belongs to the reminders app, which I do use, but it doesn't make any sense that the app has such a high CPU usage. This is not a one time thing, it happened at least 5 times in the last few weeks. I usually ended up killing the process or restarting my Mac. Quitting the reminders app does not stop the process.

What can I do to prevent this?

enter image description here

It may be related to the reminders app constantly syncing:

enter image description here

Although that opens only more questions than it answers.

I'm using the latest MacBook Pro 16" with MacOS 10.15.4 (19E287)

4
  • 1
    Can you pls include the model of your MBP and the version of macOS on it in your post? Thx.
    – Alper
    Commented May 24, 2020 at 8:30
  • 2
    . @Luca as a hit and trial attempt, turn off iCloud sync of reminders on your Mac & turn it back on.
    – anki
    Commented May 24, 2020 at 8:30
  • I added some more info to the post. I also tried @ankii's suggestion, until now the the cpu usage was normal, but I'll report back as soon when I encounter the problem again.
    – Luca Steeb
    Commented May 24, 2020 at 8:51
  • Turning off reminders sync no longer works for me. remindd has run away CPU usage even with syncing off. I updated my answer as well. Commented Nov 2, 2020 at 20:24

3 Answers 3

7

What worked for me is to turn off Reminders syncing, reboot, then turn it back on. Assuming you are running Catalina, you would go to:

System Preferences -> Internet Accounts -> iCloud -> Uncheck Reminders

It took a bit for my reminders to sync again, but after that, there were no more issues with Reminders app lockup and the remindd run away CPU usage.

However, as of recent (Catalina 10.15.7), remindd has run away CPU usage regardless if I turn off/on syncing or I just leave it off the all the time.

Since I posted this answer, I will add that even with Big Sur (including 11.3 update), so long as I have Reminders enabled, I get high CPU usage with remindd. In addition, reminders are not properly syncing between my iPhone, iPad, and Mac. It appears there is some corruption in my Reminder data and it is not getting fixed with macOS updates.

5
  • seeing the same thing after upgrading from Mojave to Big Sur. Feedback time I guess... I hate this new update -.-
    – Jon Lang
    Commented Jan 27, 2021 at 13:33
  • same here after upgrading to big sur
    – webofmars
    Commented Apr 8, 2021 at 17:40
  • So is there any way to disable remindd? At this point, I'd rather have it completely disabled rather than eating my battery...
    – Gleno
    Commented May 2, 2021 at 8:03
  • @Gleno just turn off Reminders in your iCloud settings. Commented May 4, 2021 at 12:54
  • @SwisherSweet I did, but it still kept chugging. The trick was to start the reminders app, and delete all reminders. They kept popping back, i kept deleting, and after a few tugs of war, I ultimately won. Now my reminders are completely pacified. Thanks.
    – Gleno
    Commented May 6, 2021 at 12:38
0

What finally worked for me is to delete the Reminders app from my iPhone.

I had tried turning off syncing, turning off MacOS notifications, deleting the MacOS app (following safe boot instructions that did not work), and deleting the single reminder I had in the system. Killing the process was just a temporary solution (sometimes measured in hours, other times in seconds).

Deleting the app on the iPhone finally seems to have fixed the problem.

2
  • Did you re-install the app afterwards, though? If yes, did it not continue to occur after re-installing?
    – Luca Steeb
    Commented Nov 17, 2021 at 9:41
  • I did not. I am annoyed enough that this bug has been around for so long that I am unwilling to use Reminders again. Commented Nov 18, 2021 at 15:28
-1

I use to have the same problem, so I kill the process from the command line. You have to find the PID process for that I've used top command

enter image description here

then is I use the following command:

sudo kill -9 YOUR_PID_NUMBER

After doing that you can note the difference, the fan noise decreases A LOT.

1
  • 1
    Thanks for contributing, but this doesn't fully answer the question - OP already states that s/he kills the process but wants to know how to prevent the process from starting and / or hogging the CPU repeatedly.
    – sfxedit
    Commented Jul 13, 2021 at 10:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .