0

I tried installing Catalina 10.15 from an external USB drive created on windows, because from Apple store a message "Could not contact server" appeared.

The setup was going great and at the end the iMac Late 2013 8GB RAM i5 core booted but there was only an folder icon with a question mark inside. There was no way to boot Catalina. So I instaled Mavericks on an external drive which came with the iMac when it was bought.

It all went great until I tried to update it and "Missing firmware partition" came. (Tried in both Internet Recovery and Recovery HD) I tried erasing the internal drive (drive0) in all possible formats and partition maps as well as secure options, tried to create an image but it always says that it is unable to read last block of device.

So I went through all solutions available, tried all given fsck commands trying to erase it, sometimes I/O input/output error showed and there is no partition map as well. Before I tried to install Catalina I remember I erased the disk in HFS+ format.

TestDisk analyse was tried and it couldn't find anything.

Somehow I succeed installing El Capitan and then Sierra on the external drive. After that missing firmware appeared and I searched through apple updates EFI SMC etc. but there was no update that could be installed.

VMware Fusion virtual machine was created, High Siera --> Mojave---> and it was cloned to main external drive. Everything went great but in every OSX Disk utility the internal drive couldnt be formated and it is shown uninitialized. Tried terminal commands, different disk format and recovery software, OSXFUSE, even updated bash to 5.0. nothing worked.

Installed new virtual machine OSX Catalina and cloned to USB but now it restarts at random times and I'm having troubles cloning it to main external drive.

Do you think the Internal Drive is dead, might it be just the cable, should I try Wine emulator and try Windows software to format the hard drive? I think if I try to format it in Windows it will all work great but I couldn't do it with win VM or bootcamp which requires to be installed on internal drive. I have no time machine backup.

Thank you,

Best Wishes and Catalina sucks.

  • "Unable to write to the last block of the device" seems to usually be an SATA cabling issue. – Tetsujin May 23 at 9:54
  • Try installing High Sierra from a flash drive. If successful, then try installing Catalina from a flash drive. – David Anderson May 23 at 12:44
  • @DavidAnderson , I tried installing it from flash drive and from Desktop directly but firmware missing error appears and the internal hard drive is not even shown. – Mario May 24 at 0:00

You must log in to answer this question.

Browse other questions tagged .