1

I bought a new iPhone 11 and restored the backup from my iPhone 6.

It's great except for this issue; I can't get a longer auto-lock than 5 minutes.

I spoke to an Apple support rep and we worked out it's something to do with the exchange accounts I have set up on it.

I have one Office360 exchange account and 6 AWS exchange accounts, all used for email only.

If I disable the AWS exchange accounts, for some reason I get the "Never" option back. The Office360 account doesn't affect anything.

However we weren't able to work out much beyond this.

Why could this be?

1 Answer 1

1

I logged into my AWS WorkMail dashboard and noticed that there is a "Mobile policies" menu item.

When I chose this, one of the policy options was "Enable screen lock" with a value of 300 seconds - or 5 minutes, co-incidentally the maximum value in the iPhone's Auto-Lock drop-down.

After I disabled this and cycled the exchange accounts on the iPhone, the "Never" option re-appeared.

1
  • 1
    Yah, MS Exchange can enforce locking policies on iPhones and iPads. We do it with my Exchange server. It's a good security policy, even if it is annoying. May 23, 2020 at 0:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .