The MacBook Pro was brought to me with a windows 10 bootcamp but the Mac OS portion is corrupt so it only boot to windows. When i was unable to install Mac OS Sierra on the hard drive so I removed the hard drive from the MacBook and format it in another MacBook with Mac OS extended journal format. When I insert the hard drive back to the MacBook this is the error I keep getting “Missing operating system” now I can’t install any Os on it. Any help will be appreciated enter image description here

  • Have you tried booting from a bootable macOS Installer and installing macOS from there? The installer can also act as a Recovery partition with necessary tools to troubleshoot. – Todd May 22 '20 at 17:54
  • 1
    "missing operating system" is a Windows startup error, not Mac. I suspect the disk was not properly re-formatted. Try holding Cmd/R at boot. – Tetsujin May 22 '20 at 17:54
  • Yes I have bootable macOs installer Usb but it’s not booting from it . When I hold Cmd/R it reboot and show “Missing operating system” and when it shows the bootable Usb containing the installer and I click it it will show prohibited logo. – UpIn May 22 '20 at 18:23
  • Connect to wired ethernet, hold Cmd/opt/R at boot - it should go to Internet Recovery [It should have done that already, but it needs a solid net connection] – Tetsujin May 22 '20 at 18:25

Actually this is pretty easy, if you have a network connection of some sort. Wired ethernet is generally more reliable and faster, but you need the cable and possibly an ethernet adapter, depending on the model of MacBook you have.

Boot your Mac while holding the ⌘ Command and R keys. In a minute or two you will get to the macOS recovery screen which will allow you to log into WiFi (if you are not already using ethernet) and reinstall macOS.

The system will query Apple's servers over the internet and download the latest version your Mac supports. Depending on how fast your network connection is, this could take quite a while.

It will prompt you to reboot when the installation is complete. And you will have macOS installed on your Mac.

Apple has the official details here: https://support.apple.com/en-us/HT201314

  • It’s not booting to recovery just stuck at “Missing operating system” or prohibited logo . – UpIn May 22 '20 at 18:26
  • You did notice that you have to hold COMMAND-R while the system is booting? Just pressing COMMAND-R at that screen will do nothing. – Steve Chambers May 22 '20 at 19:16
  • I have tried all that but still not working. I remove the hard drive hook it to another MacBook and I successfully install Mac OS Sierra on it but when I put it back into the MacBook it no longer show the “Operating system missing” again but still it won’t boot no apple logo only showing the prohibited logo and when I try Cmd R it does go to recovery mode only showing the prohibited logo – UpIn May 23 '20 at 17:44
  • Add the model number of your Mac to your question. It's on the bottom in VERY small print, starts with the letter "A" like A1234. – Steve Chambers May 23 '20 at 20:23
  • Better to use the Ultimate Mac Lookup as sometimes the A-ref can refer to a dozen different models – Tetsujin May 24 '20 at 7:43

Thank you all. I was able to resolved the issues by installing El Captain since the version of the MacBook Pro I have didn’t support Sierra.

  • Please share how you've managed to install El Captain. – lhf May 26 '20 at 21:13
  • Thank you. I downloaded a copy of eEl Captain about 6.5gb on another MacBook Pro laptop and I make a bootable usb drive with Disk maker X. Then I attached the usb to the MBP power on the system and I press option key then I select the flash containing the El Captain Os and the installation begins. – UpIn May 27 '20 at 7:20

enter image description here

!]3 Here is how I was able to install El Capitan

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .