0

An iPhone 8 Plus can't send / receive MMS messages (i.e. non-iMessage group messages) when on WiFi calling on Verizon - it just sits with the progress bar when trying to send and then eventually fails.

Phone calls and individual SMS messages work fine when on WiFi calling, and going down the street to where there's 4G signal causes MMS to work immediately.

A Galaxy S9+ on the same WiFi calling is able to send/receive fine. The underlying internet is 1Gbps fiber and works well.

In case it's relevant, there is extremely marginal cell tower coverage at this location (i.e. ~1 bar).

Updating iOS on the phone did not solve the issue.

1
+50

An iPhone 8 Plus can't send / receive MMS messages (i.e. non-iMessage group messages) when on WiFi calling

This is expected.

WiFi calling has no provision for sending either SMS or MMS messages that’s a function of the GSM Network. Also, MMS is multimedia messaging, not “non-iMessage group messages.” Now, as long as you’re connected to WiFi, you can receive iMessage messages.

In case it's relevant, there is extremely marginal cell tower coverage at this location (i.e. ~1 bar).

It is relevant if you have your cellular on, but signal is so low that you’re using WiFi calling instead. SMS using a very small amount of bandwidth compared to MMS, so it’s entirely possible regular SMS messages go through and MMS messages do not. Also, unlike SMS, MMS will typically not queue up and continue resending; they usually delete after a period of time, sent or not.

| improve this answer | |
  • Apple mentions that you can send SMS over WiFi calling (support.apple.com/lv-lv/HT204065 - "If you turn on Wi-Fi Calling, you can send SMS messages over Wi-Fi"), and I just tested sending an MMS with airplane mode on using WiFi calling from a Galaxy S9+ and it sends fine on the same carrier (Verizon). Is it possible what you mentioned only applies to some carriers, perhaps since Verizon is CDMA rather than GSM? Thanks – g491 May 27 at 20:59
  • From: support.apple.com/en-us/HT203032 "To use Wi-Fi Calling, you need an iPhone 5c or later on a supported carrier. " Not all carriers support all features. – Allan May 27 at 21:18
  • I'm on AT&T and have never been able to send SMS from my iPad even with WiFi calling enabled. But, if I use my iPhone, it works every time. They never get through. It could be an area thing as well. – Allan May 27 at 21:22
0

Try these steps first

1. Restart your device: iPhone iPad iPod touch Check your network connection. To send a message as iMessage or MMS, you need a cellular data or Wi-Fi connection. To send an SMS message, you need cellular network connection. If you turn on Wi-Fi Calling, you can send SMS messages over Wi-Fi.

Check with your carrier to see if the type of message you’re trying to send, like MMS or SMS, is supported.

If you’re trying to send group MMS messages on an iPhone, go to Settings > Messages and turn on MMS Messaging. If you don't see an option to turn on MMS Messaging or Group Messaging on your iPhone, then your carrier might not support this feature.

Make sure that your device has enough space to receive images and videos. Make sure that you entered the correct phone number or email address for the contact.

If you see a Waiting for Activation alert, learn what to do.

If you still need help, find your issue below to learn what to do next.

2. Another method From a Home screen, navigate: a.Settings Settings icon > Messages Messages icon. b.Tap the MMS Messaging switch to turn on Switch On or off.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .