9

I was working on my mac and saved a file. Continued to work on the file. One hour later, when I tried to save that file, I saw the message "The document could not be saved. You don't have permission". What??? Now I see I cannot save any of my files. I can open them, but I cannot save. Any file. But this is selective. TextEdit can save the files, Mail.app can open emails and save attachments. Xcode can create and save new projects, but I cannot modify them, or I will see the error if I try to save.

This is what I have tried to do:

  • chown, chmod -R 755, etc. on the directory containing my projects doesn't help.
  • Disk Utility > Repair Permissions doesn't help.
  • Reinstalling the app, clearing their .plists, etc. doesn't help.
  • I can create a new project or document with these apps (Xcode and Photoshop for example, just to name a few) and it saves the file on my documents directory, but if I change the document and try to save, I see the error.
  • I have rebooted the computer and also turned it off and on.
  • I did a safe mode boot and scanned the disk using /sbin/fsck -fy and no issues were found.
  • I have deleted all caches and application support files.
  • I did a chmod -R -N ~ on my documents directory, suspecting that some ACLs could be the guilty. No change.
  • I did a recursive chown to take ownership of my own files. The ownership was correct before, but I just did it again to clean anything that could be wrong.
  • I reinstalled both apps and nothing.

What more I can? Cry?

Thoughts? Thanks

5
  • When you say chown and chmod on your directory doesn't work, I presume you sudo'd right? That would force it to accept your permissions if you haven't already. Feb 3, 2012 at 21:09
  • yes, I did it with sudo and did it again now, just in case.
    – Duck
    Feb 3, 2012 at 21:45
  • I have created another user on my system and everything is fine from there. Something happened to this account, while I was working that made it unusable. What more can I check? thanks.
    – Duck
    Feb 3, 2012 at 21:58
  • Look at the ACL on directories etc. ls -le
    – mmmmmm
    Feb 4, 2012 at 17:55
  • this answer might be worth trying. Jan 28, 2017 at 8:17

5 Answers 5

3

I had the same problem. I tried what Matt Love has suggested and still had the problems. I then downloaded Cocktail and ran permission repair, rebooted and all worked again.

enter image description here

1
  • I'm not keen on recommending third-party software, but in this case it's the only thing that worked. I did first try repairing permissions with Disk Utility, restarting and all that, but to no avail. I run 10.7.5. I did look into upgrading to Mountain Lion but my trusty MacBook is deemed too old. Nov 23, 2012 at 14:44
1

If I understand your question correctly, you're attempting to reset the permissions on a user's home directory. This is easily accomplished by resetting ACLs on the desired home directly by using the Reset Password utility in the Recovery Partition:

  • Restart your computer from the recovery partition (if running Lion) or the gray disk (if not running Lion).

  • Open Disk Utility and run a permissions repair on your startup volume.

  • After this is complete, close Disk Utility and open Terminal from the Utilities menu.

  • Type in resetpassword and select your user account (NOT System Administrator/root) from the drop down menu.

  • Click the Reset button at the bottom of the window in the Reset home folder permissions and ACLs section.

  • Quit the Password Utility and go back to the main recovery screen. On your keyboard, hit + Q and restart your computer.

It's very important that you don't hold down the power button to exit the recovery session, or the ACL reset won't occur.

Let us know how it goes.

0
0

It may be file ownership issue. Try changing the file's ownership to yourself.

  1. Run Terminal
  2. Go to your file's folder
  3. run sudo chown <your-user-name-here> <file-name-here> OR
    sudo chown -R <your-user-name-here> <folder-name-here>

Why does it happen?

One Reason: Sometimes applications or we use "SUDO" (which is to perform actions as a super user) command to do different things. If any file is created as a super user (which is usually root) then "root" owns that file or folder.

0

I have a simple answer. Go to Save As, under Where make sure you're saving it to your documents. I kept getting this error and realized it was saving to lines. Don't know how that happened but once I changed it to saving in Documents the problem went away.

1
  • SpaceDog already said he is working in his documents directory. Nov 24, 2018 at 19:06
0

I signed up just to give this reply:

I'm a macOS expert and after experiencing this exact issue and trying what the web says and nothing worked I finally found the resolution which worked for me.

  1. Go to System Settings - Users & Groups - Create NEW USER, GIve this User Administrations rights

  2. Teen restart and log in as the new admin - then go to Macintosh HD(the internal "Hard-dive")

Then Users and then right click on the user folder that contain the troublesome files, open "GET INFO"

  1. THen go to the bottom right of the that window pop-up and click on the lock and enter the password for the currently logged in new admin user.

  2. Then select the username which relates to the troublesome files and under the "Privilege" column just change it to read and then back to "read and right"

  3. Then click on the downward arrow next to the +- at the bottom and click on "Apply to enclosed items"

This should take a few minutes or seconds but after it's done restart again, log into the old user that had the troublesome files and go try to save one of them.

I have to add: WHat you also can try before you do step 2. IS to right click on the User with troublesome files then GET INFO then click the + and add the new admin user and give it read and write permissions and apply the changes. THEN proceed to step 2 above and do the same with the user with the troublesome files.

Anyhow, this is my first an dlast time probably loggin in here. Hope it works for you... I had to re-install the Macos 3 times an d restore form backups 3 times before I tried this... I wasted a day with a 10 minutes BAhahah

New contributor
Jaco Kruger is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .