2

I bought a second hand Mac Mini from a friend a couple of years ago. I've only just got round to trying to set it up. He wiped the device before he sold it to me. I believe the device is the late 2009 2.26GHz model. It currently has 10.6.8 Snow Leopard installed.

When the device boots it goes straight into Mac OS, no login challenge. I was trying to set up screen sharing so I can remote into the device and when I attempted to secure the VNC connection with a password, I was challenged for an admin password. I tried the usual basic things to no avail. I then asked the guy I got the mini off and he cant remember what he set it to.

I've spent all afternoon trying all the different options I can find and can't get anything to work. I'm assuming my best option is to try and wipe the device. What I've tried (I'm using a Windows style keyboard) -

  1. Command - R to enter recovery mode. Tried Ctrl - R, Alt - R, Windows - R, Shift - R, none of these work. Each time it just boots straight into OS.
  2. Checked for a recovery partition. Can't see a recovery partition, is this why Command - R does nothing?
  3. Found and downloaded an El Capitan (Mac OS 10.11) image. I believe this is the latest version supported by the device. Then tried to create a bootable USB disk using Disk Utility on the Mac. When I get as far as restore I'm challenged for the admin password which I don't have so can't continue with this
  4. Tried to create a bootable USB on a Windows device using Transmac and another tool that's name escapes me. Did this with 2 different USB thumb drives. Trying them many times in the Mac. Each time booting and holding the Option key (Alt). The device boots to a screen that shows the Hard Drive only, no option for the USB drive. It has the option to log in to WIFI at the bottom of the screen (the device is connected to the network via a cable as well). I tried connecting to the WIFI which worked, but then it gave no further options
  5. Tried the various key combinations I could find to try and launch the internet recovery, is it even supported on a Mac this old? Nothing came up with any of the combinations I tried.
  6. Tried looking for a password hint, doesn't look like he set one

Can anybody offer any advice?

4
  • 1
    Recovery Mode wasn't added until 10.7, so it's normal that you don't have it. Try a single-user mode bypass like the one here to set up a new admin account, then use that to reset the password on the original one. – Gordon Davisson May 21 '20 at 23:29
  • You should be able to get this machine to boot. It seems like your running into the admin password. – historystamp May 21 '20 at 23:29
  • hold down the option/alt key then power up the machine. This will get into then startup manager. You can the pick what device to boot from. If you get into the startup manager, the machine doesn't have a firmware (boot) password set. Any other way of booting will get you to the default boot device. See Gordon's solution for changing the admin password. You not booting into your usb based os. Your booting to the default os, hence your being ask for the password to your default os. – historystamp May 21 '20 at 23:34
  • You don’t use Disk Utility to create a USB installer. Where did you get the instructions? Go to How to upgrade to El Capitan to obtain an installer and How to create a macOS USB iInstaller for version specific instructions on how to make a USB installer. A 2009 Mac mini is too old for Internet Recovery. It supported it in 2011. – Allan May 22 '20 at 1:36
2

The single user mode solved this for me. As detailed in this post - How can I reset a Mac's password from Single User Mode?

I had to use the version mentioned by Kelli, ie launchctl then passwd [username]

I now have administrator control so I can use the machine. Many thanks everyone

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .