So my Mac refuses to goto sleep because I'm running nfsd service (for work). I have verified this by typing pmset -g on cmd line. Here is my question.

  1. Without having to manually stop nfsd, Is there a way to make the auto sleep function on macOS to be more aggressive. I noticed if I manually goto the  -> sleep or hit the shortcut to sleep, it's far more aggressive and goes through the process of shutting down all services and then sleeps.

Any other ideas on how I can get this Mac to auto sleep while running nfsd? Maybe a whitelist of services to ignore while preventing sleep.


No, you can’t make it more aggressive.

nfsd is the NFS server daemon and enabling it, you’ve effective turned your Mac into a server. Servers don’t go to sleep because you’ll “kill” services your network clients rely on. Having this daemon prevent sleep is by design.

If its that important to have file sharing (NFS, SMB, iSCSI, etc.), get a NAS like a Synology Diskstation. The “entry level” 2 disk models are affordable and extremely reliable. This will allow you remove your Mac from doing double duty as your daily driver and as a workgroup file server. It even has power saving settings that will allow it to spin down the drives and even go to sleep after a period of inactivity.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .