2

Update 1: Somehow, after unconnecting and re-connecting, the original disk (disk1) has now returned to original state, with the readme file as well! I still have another disk which is not working. When connected to my MBP I get the message, "The disk you inserted was not readable by this computer." "[Initialize | Ignore | Eject]".

Update 2: @Allan's question: Like how long from when you bought the drives and were working to when they stopped? Answer: They were removed from the packaging on the day they arrived. These are brand new. They both worked out of the box. Issues started after attempting to partition and attempting to restore via Image.

Update 3: The disk currently does not work on Mac or Windows. Next steps from here?

TL;DR:

I ordered two external hard disks and tried them on the first day they arrived. They appeared to work as a normal external hard drive when I first connected them to my MBP (Retina mid-2015, Yosemite 10.10.3). However, after trying to partition/restore via Disk Utility, they become both unusable. NB. One of them returned to original state — please see Update 1, 2 and 3 above. So please also see my attempts at a solution in my answer to this question as advised by @bmike

If these types of 2.5" external hard disks are actually not compatible with Macs or Time-Machine backups:

A) What can I do to return the disk back to its original usable/exfat state?

B) In their original Exfat state, to what extent will they be usable?

C) Why are they limited to Exfat format?

D) How, without the seller telling me, can I know these are limited to Exfat format only? e.g. Are certain cheap 2.5" external HDDs from China always limited to Exfat?

Quick Intro: I first tried to partition one of them. This made it unusable. After attempting to restore the first one by copying/cloning an image from the second one, the second became unusable. Then somehow the first disk randomly became usable again and was back to its original state (it even contained the original readme file).

Context:

I want to do a Time Machine backup to an external hard disk so I bought two 2.5” 2TB external hard disks.

The hard disks (both identical) were described as compatible with macOS, both on packaging and on the online description. I connected one of them for the first time and all looked normal. The only exception is that I found a readme file, which mentioned this drive can only be formatted to Exfat.

So my conclusion is that the drive is officially in NTFS format, while the readme file says it's Exfat only and the online description and packaging say's it's compatible with Macs. I contacted the seller, who replying saying that it doesn’t work with PS4 and is compatible with Windows, Mac, Xbox and Linux.

So after attempting to partition 1.1GB for Time Machine, Disk Utility gave me the message “Unable to write to last block of device”. In an attempt to salvage the first disk, I wanted to basically copy/clone the second external drive in its original format and burn it onto the first one that no longer shows a volume. I plugged in the second disk and tried to use the ‘Restore’ function via the Restore tab and clicked on the ‘Image…’ button. I then got a message saying:

"Unable to create “JMicron Generic Media1.dmg.” (Input/output error)."

The first screen shot is what the hard drive first looked like when connected to my MBP. The second shows what it's like after it became unusable. Below that are screen shots in chronological order, whilst attempting @Allan's suggestion.

enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here enter image description here

  • OK - this is getting bumped repeatedly so I'm going to lock the comments for a day. This needs all the tries in an answer and probably an edit to get it down to three / maybe four facts. Everyone can collaborate on answers much better than on a moving target that changes 10 times a day. – bmike May 23 at 17:24
  • Comments are not for extended discussion; this conversation has been moved to chat. – bmike May 24 at 13:08
1

As per @bmike's suggestion. I'm putting my attempts at solutions in this answer to avoid repeatedly bumping the comments section and to clean up the original question.

As per @Allan's advice I formatted the drive to Exfat on Windows, although the "format did not complete successfully". On Disk Utility I now can see a greyed-out volume named Disk1s1. However, I still get the message, "The disk you inserted was not readable by this computer." "[Initialize | Ignore | Eject]", when connecting to my MBP. Moreover, the 'First Aid' option in Disk Utility is greyed out.

Now, diskutil list command result gives a volume type of DOS_FAT_16. Compare this with the previous results that shows the original (working) and previous (unusable) states.

The disk currently does not work on Mac or Windows. Next steps from here?

--

Currently the disk is unusable but with greyed-out disk1s1 in disk utility. /dev/disk1 gives:

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *2.0 TB     disk1
   1:                 DOS_FAT_16                         2.0 TB     disk1s1

sudo gpt -r -v show disk1 gives:

gpt show: disk1: mediasize=2000398934016; sectorsize=512; blocks=3907029168
gpt show: unable to open device 'disk1': Input/output error

sudo diskutil verifyDisk /dev/disk1 gives:

Unable to verify this whole disk: A GUID Partition Table (GPT) partitioning scheme is required (-69773)

diskutil info /dev/disk1 gives the following:

   Device Identifier:        disk1
   Device Node:              /dev/disk1
   Part of Whole:            disk1
   Device / Media Name:      JMicron Generic Media

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Content (IOContent):      FDisk_partition_scheme [PREVIOUSLY THIS WAS "NONE"]
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 USB
   SMART Status:             Not Supported

   Total Size:               2.0 TB (2000398934016 Bytes) (exactly 3907029168 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                Yes

   Whole:                    Yes
   Internal:                 No
   OS 9 Drivers:             No
   Low Level Format:         Not supported

Previously the results were:

Nonexistent, unknown, or damaged partition map scheme
If you are sure this disk contains a (damaged) APM, MBR, or GPT partition
scheme, you might be able to repair it with "diskutil repairDisk /dev/disk1"

diskutil repairDisk /dev/disk1

Nonexistent, unknown, or damaged partition map scheme
If you are sure this disk contains a (damaged) APM, MBR, or GPT partition map,
you can hereby try to repair it enough to be recognized as a map; another
"diskutil repairDisk /dev/disk1" might then be necessary for further repairs
Proceed? (y/N) y
Error repairing map: POSIX reports: Input/output error (5)

diskutil partitionDisk disk2 1 GPT JHFS+ "Untitled" 100%

Started partitioning on disk2
Unmounting disk
Error: -69760: Unable to write to the last block of the device

Here's what I've had a look at (but not sure if it applies to my case):

http://www.macissues.com/2014/04/05/how-to-fix-deep-formatting-problems-with-os-x-drives/ (I attempted cat /dev/random > /dev/disk1 once only, but got a stdout: Input/output error response)

https://ipfs-sec.stackexchange.cloudflare-ipfs.com/apple/A/question/125965.html (I tried diskutil eraseVolume exfat exfat2tb /dev/disk1 but got the following:

Started erase on disk1
Unmounting disk
Erasing
newfs_exfat: 
wipefs_wipe: Input/output error
Volume name      : exfat2tb
Partition offset : 0 sectors (0 bytes)
Volume size      : 3907029168 sectors (2000398934016 bytes)
Bytes per sector : 512
Bytes per cluster: 131072
FAT offset       : 2048 sectors (1048576 bytes)
# FAT sectors    : 120832
Number of FATs   : 1
Cluster offset   : 122880 sectors (62914560 bytes)
# Clusters       : 15261352
Volume Serial #  : 5ec6682e
Bitmap start     : 2
Bitmap file size : 1907669
Upcase start     : 17
Upcase file size : 5836
Root start       : 18
Mounting disk
Could not mount disk1 with name (null) after erase
Error: -69832: File system formatter failed

Previously (unusable disk):

       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:                                                   *2.0 TB     disk1

Originally (working disk):

       #:                       TYPE NAME                    SIZE       IDENTIFIER
       0:     FDisk_partition_scheme                        *2.0 TB     disk1
       1:               Windows_NTFS                         2.0 TB     disk1s1
| improve this answer | |
  • Thank you so much. Would you now be able to edit the question down to one question? – bmike May 23 at 21:58
  • 1
    @bmike you're very welcome. If you mean the ABCD questions, I've now striken-out BCD and kept A :) – questioner56 May 23 at 22:17
  • Thanks. I may try an edit when I am back at the computer. Thanks so much for being flexible. It will help get some more answers. – bmike May 24 at 1:13
  • You're very welcome. :) – questioner56 May 25 at 11:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .