1

I've just got a second hand MacBook from my dad which is a 2017 version with 250GB storage. I've factory reset it so theoretically it should be a completely blank slate, but for some reason I'm losing disk space already. Every couple of minutes the available space shrinks; it seems I lose 100MG every ten minutes or so. I'm currently on 231.52GB free, and it was at least 235 a few hours ago.

I know this began as soon as the computer switched on because the first thing I did was to check the storage space and I immediately noticed that it was going down. I'm not downloading anything at all from the internet, my downloads folder is completely empty.

This is really frustrating to me, not to mention making me a bit paranoid about when it's going to stop and how much space I'll have lost when it does. The whole reason I got this Mac was for the better storage as my previous one was less than half the size (120GB) and it was causing big problems. And granted it's only small chunk of the overall storage gone so far, but I'm gonna be using a lot of big files on this machine and I need all the space I can get. Does anyone know why this is happening and how to stop it? I'm wary of even downloading anything else until I get to the root of this problem.

  • Are you signed into an iCloud account? If so, it's syncing your content to this Mac. – fsb May 20 at 20:42
  • Yeah I think I am. Is there anyway to stop it doing that? I don't really need it tbh, I've backed up my old machine onto a drive. – t0mkat May 20 at 20:56
  • @t0mkat You have to disable iCloud Drive in iCloud Preferences. This will prevent iCloud from storing files on your Mac. You can still browse your files from iCloud.com. – Todd May 20 at 21:05
  • Thanks for your comments but unfortunately it has kept going down. I'm now on 230.88GB. It's difficult to know if it's stopped because it can stay on a given amount for like 20 minutes before going down again (sometimes it fluctuates up and down, which is weird). For the record, what I did was go into System Preferences > Internet Accounts > iCloud (in the sidebar) and unchecked iCloud Drive. I also unchecked everything else except for Siri, Find My Mac and Home. If I've missed something do let me know. Thanks – t0mkat May 20 at 22:59
  • 1
    Do you have Time Machine switched on but don't have the Time Machine volume connected? In that case the OS is storing Time Machine files locally which will be transferred to the TM volume once it is connected. – Peter Kämpf May 21 at 3:54
1

I think having 235GB free space on a 256GB SSD Macbook Pro is not very likely on an active system. 256GB SSD Mac normally has about 250 GB of available space. The system and pre-installed apps would easily take much more space than 15 GB.

On the other hand, mac storage reporting can dynamically change (up or down) as calculations take place. You might have been observing that going up and down in calculations.

On a fresh installed OS, much things can be going. For example, spotlight might be building an index. As you browse web-sites, Safari or Google chrome will also be building up its cache. Likewise, if you use Spotify, even it will cache the songs you are listening. Therefore, I suggest that you use the system for a while and then see if the storage calculations settle down.

When the things settle down, you can make an analysis of used space and try to see if everything is normal or not. Hope that helps.

| improve this answer | |
-1

Go to System Preferences -> iCloud and when that panel opens the checkbox next to iCloud should be checked. If so click on the Options button on that line. When another new panel opens, there is a checkbox near the bottom that says Optimize Mac Storage. Reverse this setting (if it's checked, uncheck it, if it's unchecked, check it).

| improve this answer | |
  • This will continue to store files on the Mac. According to Apple Support, you must disable iCloud Drive to prevent files from syncing to the Mac. – Todd May 20 at 21:31
  • Have you verified that your self? – jmh May 20 at 21:40
  • Yes, I have verified this and when I contacted Apple Support, I was told that Optimize Mac Storage will not help (checked and unchecked). It might work for some people but it seems Apple doesn't think so. – Todd May 20 at 21:41
  • well i'm out of options. i suppose you have to go back to the System Preferences -> iCloud and uncheck the iCloud Drive box. – jmh May 20 at 21:57
  • I suppose your solution could work with a larger iCloud Plan but usually not with the free 5GB because macOS would be unable to store things in iCloud because of the storage limit so storage would still be used. – Todd May 20 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .