0

2010 iMac running OS X 10.12.6 is failing to start up (progress bar gets to about 75% and then it powers down). I have exhausted all of the following to try to at least salvage some files:

  • Go to Recovery Mode (Command+R): had no effect (recovery mode did not start)
  • Safe Mode (Shift): had no effect (safe mode did not start)
  • Reset your PRAM. Shut down your Mac and hold down Command-Option-P-R during boot. Wait for the chimes and let go. (Worked but had no effect)
  • Apple Hardware Test (press and hold the D key while booting your Mac): had no effect; the Apple Hardware Test icon never appears

My last resort (since I don't have a Firewire cable and so Target Disk Mode transfer is not an option) is to start up in Single User Mode and try cp the files over to an external HD. After plugging in the external drive and seeing what it is called at /dev/disk*, I try to mkdir in /Volumes (e.g. /Volumes/extdrive), but I this gets blocked with due to the fact that "MacinsoshHD is a read-only filesystem".

So /sbin/fsck -fy and mount -uw / are prerequisites to mounting the external drive. But /sbin/fsck -fy does nothing for a few minutes then finally results in the error "Could not recover SATA HDD after 5 attempts terminating", then powers down. If I go straight to mount -uw /, it does nothing (the iMac powers down after a couple of minutes).

What other options are open to us to try mount the external drive?

3
  • Does your Mac support internet recovery? From there, you can try running Disk Utility's first aid, then try copying the files to your external HD. Also, if the HD is damaged (as it seems to be) you may not be able to copy the files at all.
    – At0mic
    May 20 '20 at 6:02
  • @At0mic But doesn't internet recovery go straight to re-installing OS X, which will wipe the files of the hard disk?
    – Pyderman
    May 20 '20 at 20:12
  • @At0mic Gave that a try; internet recovery mode did not start (it just tried to startup normally).
    – Pyderman
    May 20 '20 at 20:39

You must log in to answer this question.

Browse other questions tagged .