0

I'm trying to upgrade my version of powershell to the latest version 7.0.1 using brew. The install seems to be stuck on disabling some ruby gems and is constantly asking over and over again for my password. I've tried uninstalling as well and I get the same password loop over and over again. I know I'm putting in the correct password as when I intensionally put in the wrong password I get the sorry message before it asks for my password again.

I'm a bit stumped as this point on what else to try besides removing the two folders that contain the powershell files.

How can I correctly uninstall powershell that was installed using brew if the uninstaller won't work?

4
  • Have you tried uninstalling and reinstalling Homebrew?
    – Todd
    May 19 '20 at 23:11
  • I'll try that now. I have done the update reset they suggested.
    – Aaron
    May 19 '20 at 23:15
  • @Todd thank you that fixed the issue. Why does brew ask for your password for every action? I know sudo can hold on to it for a period of time.
    – Aaron
    May 19 '20 at 23:26
  • I will add this as an answer, can you please accept it?
    – Todd
    May 19 '20 at 23:28
0

The best step right now would be to uninstall and reinstall Homebrew. Sometimes Homebrew can be damaged and uninstalling and reinstalling it from the system will fix that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .