I recently partitioned my SSD as seen in this question MacOS wont boot after partitioning my SSD. After fixing this I tried to create a new partition in the macOS Disk Utility program. I have enough space to resize my main partition in order to create a new one. But in the end of the partitioning process I get the following error (translated to english from german; picture of error in German at the end of the question):

deactivate volumes
deactivate volume "spiele" on disk2s1
delete volumes
delete container
delete former APFS-Hard Disk
change without content type
invalid name.
action failed

After that it creates two partitions instead of one. For example: I want a 200 gb partition. The operation fails and it creates two 200 gb partitions. If i want to delete them I can, but then it shows me that my main partitions new space ist 1100 gb (the SSD is 1 tb big).

I am running MacOS High Sierra on a iMac12,2. I have the rEFInd boot manager installed in order to change between Kali Linux and MacOS.

Error (German)

Partition window in Disk Utility

1 Answer 1


If I'm correct, this is the same bug I had with APFS, because APFS creates a container and then fills it with virtual partitions (volumes).
I'm not sure this is the good way to do the trick but I created partitions formated as exfat for example and then format the partitions to the file system you want ?

  • I tried that one. It doesn't give me an error after partitioning but it creates two partitions (2x 150 gb that still wouldn't work because my SSD is only 1 tb big): screenshot Commented May 18, 2020 at 16:27
  • The Festplattendienstprogramm is quite broken, what about diskutil list in Terminal ?
    – 375914
    Commented May 18, 2020 at 16:32
  • When I type in diskutil list into Terminal I get the following results: result diskutil list. Only one partition shows up, the other one not. Commented May 18, 2020 at 16:40
  • I think you are right and my Disk Utility program is just broken. I restarted my computer and now only one partition shows up. Thanks a lot! Commented May 18, 2020 at 16:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .