0

So first of all I have little experience on this field, but I'm trying to install linux on my personal MacBook Pro from 2017.

I followed a lot of tutorials for this but none of them worked. So I figured I'd ask here.

I have a 64gb SanDisk Ultra Media USB stick lying around. I got it here: https://www.mediamarkt.nl/nl/product/_sandisk-ultra-usb-3-0-flashdrive-64-gb-1262970.html

I grabbed a ubuntu copy from the official Ubuntu website, used Etcher to flash to ISO on the stick. Everything seemed fine, so I eject the stick, restart my macbook into startup manager, but the USB isn't there. Only my internal hard drive shows up. After reading a lot of forums I read that the USB stick should be erased first with GUID partition.

So, I did that, but after flashing I checked Disk Utility and saw that the partition was reverted back to the standard Apple-partition scheme.

What am I doing wrong? All these miracle fixes I see on the internet never work for me, and people say it's so easy to install Linux on your Mac. Well, I also have a MacBook from work, with Catalina, and have the same problem with that one too!

Any help would be appreciated

12
  • Try to format it in any other device, any format type, give it a new name. Eject afterwards then re-insert. Does it still appear to revert to the original structure? If so, the firmware write-protect has been triggered & the stick is toast, I'm afraid.
    – Tetsujin
    May 16 '20 at 10:05
  • Okay well, then it's probably toast. I tried your steps and after flashing it reverted back to apple partition May 16 '20 at 10:29
  • There's a more detailed workthrough on our sister site, Super User - superuser.com/questions/1125282/… - which might be worth a look at, but I wouldn't be too hopeful, sorry.
    – Tetsujin
    May 16 '20 at 10:33
  • Well, I just tried another USB stick, same problem :/. Just wanna install linux man :( May 16 '20 at 11:59
  • 1
    @Tetsujin that was the problem at the end! I tried a different connector and it worked this time :) May 18 '20 at 8:57
2

In my case it seemed to be my USB-C to USB-A connector. I used a different one and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .