If I Shut Down my MacBook, when I turn it on it automatically opens Stickies, Keychain, Activity Monitor and SketchBook.

None of these have 'Open at Login' ticked.

How do I change the settings so none of these open automatically?

2 Answers 2


Open up System Preferences then search for Login Items i1

Then find the list of items and delete the ones you dont want to open. i2

Note: You must click the subtract button or else the item will still open up. I don't know what the tick does but the item will still open even if its not ticked. The application must disappear from this list or it will continue to open. (eg. Docker, Thor and Kawa are not ticked yet they still open on startup for me)

  • There is nothing left in my list but Activity Monitor still opens on startup May 16, 2020 at 8:03
  • try the methods listed here and here
    – Roxiun
    May 16, 2020 at 8:42

By default, MacOS relaunches the apps that were open at shutdown, the next time you restart.

To stop this, in System Preferences > General, deselect the option "Close windows when quitting an app", or deselect the checkbox in the Restart dialog "Reopen windows when logging back in".


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .