1

I wanted to install Atop which required SIMBL to be installed. Nothing at the process stated that SIMBL 0.7.5 wasn't compatible with Mojave 10.14. It started to pop confirmation if I want it to control xyz application. I then started to check to uninstall it and loss a lot of time.

The process is commented in here https://github.com/w0lfschild/mySIMBL/issues/102 1. Disable SIP:

Boot into Recovery mode: Restart and hold cmd+r
In Menu -> Toolings -> Start “Terminal”
$ csrutil disable; reboot
  1. Run the script and perform uninstallation. It deletes a list of files. https://github.com/w0lfschild/mySIMBL/issues/102

  2. re enable SIP

    same as (1) change to "enable" to re-enable SIP

THE PROBLEM IS A DAEMON mySIMBLHelper IS NOT UNINSTALLED

I checked the files that it opens, and there are at least 2 places that are not deleted by the script:

"$HOME/Library/Caches/org.w0lf.mySIMBLHelper"
"/private/var/folders/tl/*/T/AppTranslocation/*/d/mySIMBL.app"

However the second one, can not be deleted because is a mounted file and it contains a copy of the original mySIMBL.

I tried restarting in SAFE MODE holding SHIFT at boot to force the flush of temp files but didn't worked.

The to gather more information I got to dump with launchctl

launchctl dumpstate > dump.txt

It shows up dozens of services with the next line included

domain = com.apple.xpc.launchd.domain.pid.rg.w0lf.mySIMBLHelper.3734

while it also shows that service as well

com.apple.xpc.launchd.domain.pid.rg.w0lf.mySIMBLHelper.3734 = {
    type = process
    handle = 3734
    active count = 27
    on-demand count = 1
    service count = 26
    active service count = 0
    activity ratio = 0.00
    originator = /private/var/folders/tl/yytk78b9195dbtvrhmhvfn100000gn/T/AppTranslocation/D5C172B8-7F7A-4E7E-B147-18B24DD76FDA/d/mySIMBL.app/Contents/Library/LoginItems/mySIMBLHelper.app/Contents/MacOS/mySIMBLHelper
    creator = mySIMBLHelper.3734
    creator euid = 501
    uniqueid = 3734
    external activation count = 0
    security context = {
        uid = 501
        asid = 100064
    }
...

I need help to uninstall it or to stop it from running.

I can't even find the file where it is fired.

Could you help me please?

1

Ok.. So I found the way myself. The next are all the files that need to be added to the script. I deleted them manually, so I am not sure if it will work without editing.

With this, mySIMBLHelper stoped starting and all the dumpstate shown with by launchctl. Hope it helps.

"$HOME/Library/Caches/org.w0lf.mySIMBLHelper"
"/private/var/folders/tl/*/T/AppTranslocation/*/d/mySIMBL.app"
"/private/var/folders/tl/*/C/org.w0lf.mySIMBLHelper"
"$HOME/Library/Preferences/org.w0lf.mySIMBL.plist"
"$HOME/Library/Preferences/org.w0lf.mySIMBLHelper.plist"
"$HOME/Library/Caches/org.w0lf.mySIMBLHelper"

Don't try SIMBL !!

1
  • You can dump the related files via find / -name *mySIMBL* -print 2>/dev/null and run rm -r for all. To remove the agent use sudo rm -r "/Library/Application Support/SIMBL/SIMBLAgent.app/Contents/MacOS/SIMBLAgent"as explained in GitHub mySIMBL Jan 1 at 19:25
0

try these commands to completely remove it launchctl list | egrep {SIMBLAgent} and launchctl remove {SIMBLAgent}

1
  • That does not remove it - it might stop it running
    – mmmmmm
    Jul 10 at 10:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .