0

I am trying to find out why my MacBook Pro will not connect to my QNAP NAS. When attempting to use Finder in macOS to access the files on the NAS, it tries to connect but fails each time. When attempting to click "Connect As..." at the top right of the Finder window, it simply attempts to connect again without prompting you for a username and password as it typically would in the past.

Things that I can confirm:

  • All other computers on my network (Windows and Linux) are able to access the NAS
  • The MacBook has been able to connect to the NAS successfully in the past with no problems, however, I don't recall how far back it stopped working
  • I can ping the NAS IP Address from the MacBook
  • I have ensured that the NAS settings have Apple file sharing protocols enabled
  • The NAS does appear in the Finder window's sidebar, you just cannot access it.

Equipment:
- Macbook Pro (Mid 2015) running macOS Catalina 10.15.4
- QNAP TS-251 NAS w/ most recent updates.

3
  • Catalina has deprecated AFP. Since you're connecting with Window clients, just stick to SMB. Try this to connect: smb://nameofnas.foo and see if you get connected.
    – Allan
    May 11 '20 at 21:30
  • I have a QNAS and can confirm that you are best off connecting via SMB. Apple uses SMB natively now. make sure in the QNAS control panel that Network & File Services > Win/Mac/NFS > Microsoft Networking is turned on, that should ensure you get in reliably. May 12 '20 at 15:21
  • Thanks for the responses. Unfortunately, I have tried using smb://nasaddress and it still does not work. I logged into the NAS to ensure that SMB is enabled as well and also disabled AFP just in case. Still no luck.
    – Chris
    May 15 '20 at 2:30
0

Connecting via SMB will be fixed in the latest update.

Had the same issue on my TS-251+ 2-bay. At one time I just pointed it down to Apple and 3rd-party hardware limitations (as I always tend to do with Apple. Hey, it either just works or doesn't just work, but then QNAP surprised me with the response. Let's hope it succeeds.

For reference, my firmware right now is: 4.5.3.1670

FYI, yes AFP may be long-in-the-tooth, but it's the only way I currently connect in Catalina 10.15.7 until SMB works again

Usually, a restart fixes the occasional loss AFP issue, but I have also had success disconnecting the network on Mac and reconnect (it's also helped me access the web GUI at times too).

So the more I think about it, the more it makes sense Apple only likes the hardware to work better.

Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .