2

Whenever I attempt to take a screenshot using Terminal (command: screencapture -is ~/Desktop/insertimagename.jpg), I receive an image of the desktop background. Despite taking a screenshot of programs in fullscreen mode, I still receive images of my naked desktop background.

I used to be able to take screen-capture of images with the aforementioned command with no problem. I suspect that I may have accidentally altered a setting or two in Systems Preference a few days ago.

I am still able to take screenshots successfully with the shortcut "command + control + shift + 4" and "command + shift + 3," however I am not able to do so with Terminal.

Is there a way I can return to taking screenshots with Terminal? I've attempted other command lines in Terminal (e.g., "screencapture ~/Desktop/screenshot.jpg"), however I still receive images of the naked desktop background.

1
  • I'm also encountering this. Trying to use Terminal from Keyboard Maestro (same problem using KMs inbuilt Screen Capture routine).
    – amergin
    Nov 25, 2020 at 16:04

1 Answer 1

3

Your terminal needs access to record the screen. Namely, System Preferences -> Security and Privacy -> Privacy -> Screen Recording and check the box for your terminal. This fix worked for me on 10.15.7.

1
  • 2
    If using cron to schedule screencapture, from the Screen Recording privacy menu you have to click the + button, press Shift+Command+G, type /usr/sbin/cron, and then click open.
    – dnlbrky
    May 1, 2023 at 1:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .