The Problem

Since I got my new Macbook Air 2020 (with i5 Upgrade), I encounter a strange and annoying problem every day: The MacBook suddenly looses connection to my USB devices. Namely my external wired Logitech mouse and my Native Instruments Komplete Audio 6 audio device (both are not native USB 3, but USB 2 devices).

Under heavy load this can happen every 5 minutes. But usually this happens every other hour with normal usage.

Update June 19, 2020: By now many others are experiencing the same problem here, here and here. It seems to be a common problem across the MacBook Pro and MacBook Air line from 2020.

My Thoughts & What I Did So Far

First I thought it is correlated to the kernel_task issue, because CPU temps are always quite high (80 idle, 90 light web browsing, 100°C Full HD media playback) and the kernel task seemed to take quite a lot of cpu. After checking the activity monitor every time this happens, I'm not sure if this is the issue. Kernel task is fine 95% of the time.

Then I tried removing things 1 by 1 from the Macbook and testing with different hardware that works fine on all other Macs. No matter which adapter (Anker USB-C to USB-A, latest Apple Multiport Adapter) or mice (two different wired Logitech USB-A mice) I used, the issue still appeared.

In my default setup I use the latest Apple Multiport Adapter, plugged in with 30W power, FullHD HDMI Monitor and my wired usb-a Logitech mouse. The HDMI connection is always fine, while the USB connection drops. 2-3 times also the Macbook didn't charge anymore, though it was plugged in. But this might be a different issue, which only happened a few times in the last 3 weeks i have the machine.

Also quitting all tools (apart from a browser trying Brave or Safari) and uninstalling USB Overdrive did not change the situation.

I did a SMC Reset and a system diagnosis (no problems found). The official Apple support suggested trying safe mode, though almost every program is slow and rather unusable in that mode. So this is not a solution either. Although I just got the MacBook less than two months ago, i also reinstalled MacOS. Still the issue is the same. It got even worse, since after every unlock now the USB mouse is not responding. This was not the case before reinstalling MacOS.

I am still not sure if this is a hardware or a software problem. Though, I'm leaning to hardware since my other Macs with a very similar setup don't have this problem. It might be a driver issue with the new CPUs or a bug in MacOS Catalina that is specific to 2020 MacBooks.

Only Temporary Fix: Unplugging

The issue is temporarily fixed by unplugging the USB mouse from the Macbook, waiting for a few seconds, and then plugging it back in. Though this works only 50% of the time. If it doesn't work, I have to remove the whole USB-C Multiport Adapter and plug it back in. And in 10% of the time even this doesn't work immediately. Alternatively a system restart also helps. But this is of course not the solution if this happens 10-15 times a day.

Would love to hear your thoughts and possible solutions :)

  • 2
    My first thought is that you're oversubscribing the power on the USB bus. I would start by getting a high quality powered USB-A hub and plug that into the multiport adapter. That Audio 6 device looks like it can draw a lot of current.
    – Allan
    May 8, 2020 at 21:01
  • Thanks @Allan! Unfortunately the issue appears in the same frequency when the Komplete Audio 6 is not connected at all. I also tried using a different, stronger power supply (from a previous MBP). Still the same issue. If i can get my hands on a powered USB-A Hub, i will test it. Though I think plugging in only the external mouse into the original Apple Multiport Adapter should work no matter what - but it doesn't.
    – iOSapps.de
    May 9, 2020 at 8:35
  • The reason for the powered USB hub is that there’s only a limited amount of current available. Putting a bigger power supply on your Mac doesn’t increase what’s available. You need to supplement the power on the USB bus, thus the powered hub requirement.
    – Allan
    May 9, 2020 at 15:35
  • You are right, i have to test it at least. Nevertheless the Macbook should be able to handle one simple USB mouse. There is nothing else externally (apart from the Multiport Adapter it is all plugged into) that draws any power.
    – iOSapps.de
    May 11, 2020 at 9:27
  • 1
    The new Mac M1 has the same problem, I am experiencing this even without anything plugged in other than my mouse and keyboard. Something is really wrong here.
    – lzap
    Feb 28, 2021 at 19:37


You must log in to answer this question.

Browse other questions tagged .