0

If I want to connect to a netatalk AFP share with my Mac, Finder gives me this error: "There was a problem connecting to the server "atrium". Check the server or IP address, and then try again." OK

So I tried mounting the share from the command line:

delta:/u# mkdir /Volumes/data
delta:/u# mount_afp -i afp://user@atrium/data /Volumes/data
Password: ****
mount_afp: AFPMountURL returned error 6, errno is 6
6delta:/u# 

The logs show:

May  7 19:48:38 delta kernel[0]: AFP_VFS afpfs_mount:  Failed to get Client ID 6
May  7 19:48:38 delta kernel[0]: AFP_VFS afpfs_mount : BAD MOUNT  on /Volumes/data (error = 6)

I googled and the only place this problem is described (but without solution) is: http://www.mactalk.com.au/showthread.php?t=41809

I tried using this mac to mount a share from another Mac, that would not work either, same errors.

I run Mavericks. I would update if I could, so that is no option. I used another Mac running Mavericks to open that same share, that is working flawlessly. So the error is with this Mac. What is error 6? What is a Client ID? What to do?

You must log in to answer this question.

Browse other questions tagged .