1

The Problem

The scenario is a familiar one, I'm able to FaceTime and Message with someone, but we can't seem to share screens.

Here's the details that make it interesting:


Symptoms

  • If I initiate the request, he gets an invite, accepts, but I get a no connection error message.
  • If he initiates the request, I get an invite, accept, but nothing happens (he sees a no connection message).
  • Connection fails either way.

But These Work

  • I can Screen Share with other people just fine, so it's only with him.
  • He and I can FaceTime each other, either initiating, and on multiple devices.
  • He and I can Message each other, either initiating, and on multiple devices.
  • He can access the full of the internet, with no issues.

His Settings

  • His Firewall is off.
  • His Screen Sharing is on. (Plus, we've toggled it.)
  • The 'Anyone may request permission to control screen' is on.
  • There so general VNC password, and that option is not selected.
  • His Remote Management is off. (Plus, we've toggles it.)
  • I have an Admin account on his computer, if that helps.
  • We are on separate networks, separated by 200 miles, each behind a NAT router.
  • He does not have anything between him and his router, like a firewall.

Stuff We've Tried

  • We've checked for a NetAuthAgent process based on dated answers found here, but there isn't one.
  • We've signed him out and back in to iCloud... no change in behavior.
  • We've tried connecting to him with El Captain, Mojave, and Catalina... identical behavior.
  • We've both more than tripled-checked the settings on his machine matches mine. He sends me screen shots to verify.
  • I've verified I can Screen Share with other people, just not him. I used to be able to.
  • He can't Screen Share with anyone. We strongly suspect it's his machine.
  • We've tried using Messages to initiate the screen share.
  • We've tried using Screen Share to initiate the screen share.
  • We've tried initiating a screen share when running FaceTime (we know the bytes are flowing) and not running FaceTime (maybe it needs the i/o channel).
  • He seems to have a rock solid internet connection with no drops, latency, or errors.
  • We've rebooted, many, many times.
  • I've looked on search engines, StackOverflow, and here for ideas. Nothing stands out.

Other Useful Notes

  • He's Screen Shared with me several dozen times over the last decade. (He knows how.)
  • It used to work all the time, before he took his computer to the Apple store and they reloaded a fresh copy of the OS on it. It wasn't working with Catalina, and they rolled him back to Sierra after discovering a performance bug in Catalina, plus he had an old 32-bit app he needed. The machine screams with performance, and hardware-wise it is the better equivalent of a current entry iMac.
  • Everything else, is working fine... only connecting via Screen Share.
  • We're both using Apple IDs to connect to one another.

Can anyone think of any other diagnostics things to try or other reasons it might not be working?

[ I'm strongly motivated to solve this, since he has Parkinson's disease and needs help when things get bad. ]

0

You must log in to answer this question.

Browse other questions tagged .