0

Most notably my Mail.app and Notes.app perform text replacements of .... to , which I do not want.

I do have text replacements globally enabled and want to keep it that way, but I have deleted a previously existing replacement rule of these ellipses a while ago and rebooted since then. Elsewhere this replacement does also no occur, e.g., while the specified replacements work fine in this input here, the ellipses replacement does – also correctly – not happen.

How can I convince Mail.app (and Notes.app) to not perform this substitution?

This is on Catalina (10.15.4).

1

I'm able to get the behavior you want by disabling Edit > Substitutions > Smart Dashes per app. It appears ellipses are grouped with dashes.

If you want to use N and M dashes, they can be typed with ⌥- and ⌥⌘- , respectively.

image of described menu command

  • Thanks, that works. Typical Apple:-(putting ellipses into dashes is not outrageous, but it did not occur to me beforehand:-) – yogik May 2 '20 at 7:18
  • The other interesting point (question) is why there is actually a set of global settings (on the side of System Preferences –> Keyboard –> Text) and then the in-app settings, seemingly overriding system settings. – yogik May 2 '20 at 7:23
  • Presumably the reasoning is just that: to be able to override the system settings per app. For example, I want smart quotes in any app I use to write, but none of the ones I use to code. – Bryan May 3 '20 at 22:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .