I have a late 2013 13-inch Retina MacBook Pro, which I just upgraded from Sierra to Catalina. Overall, everything still seems to work, but the dictionary popup that shows when I triple-tap on a word is messed up. This is what it looks like: No Local Dictionary Available error

I tried clicking the "Configure Dictionaries" button and I don't see the choices I usually see. It looks like this: Dictionary with missing choices

I tried restarting my Mac, and searching on Google and this site for solutions, and I couldn't find anyone who ran into quite the same problem, or any fix for this.

Does anyone here know how to make my dictionary work again?

Update: I found this thread on Apple's message board.

The Apple-recommended solution didn't work for me. I'm using an external hard drive as a Time Machine backup, and I found a backup of my /System/Library/Assets/com_apple_MobileAsset_DictionaryServices_dictionaryOSX folder that is recent but from before upgrading to Catalina. My laptop's hard drive has a /System/Library/Assets folder, but it does not have a com_apple_MobileAsset_DictionaryServices_dictionaryOSX folder within it, and Finder is not letting me create one. I don't see the "New Folder" option like I usually do. I tried dragging the folder from my backup and nothing seemed to happen. I tried using the Time Machine app to restore the folder and I got a dialog saying "“” can’t be modified or deleted because it’s required by macOS.".

I also tried the suggestion in the thread of restoring my /Library/Dictionaries folder, but I can't find it anywhere on my built-in hard drive or my backups.

Update 2: I disabled System Integrity Protection as described here, and looked in my /System/Library/Assets folder, and most of the stuff was missing. I hope I didn't mess up anything. I managed to copy the com_apple_MobileAsset_DictionaryServices_dictionaryOSX folder from my Time Machine backup, and it seems like it didn't fix anything. I restarted my laptop and triple-tapped on a word, and the Dictionary app came up and said it was preparing the downloadable dictionaries (or something similar; I don't remember exactly), which gave me some hope, but after that finished, the same things were happening ("No Local Dictionary Available", usual dictionaries not showing). I restored my /System/Library/Assets folder from my latest backup (from before the upgrade), re-enabled System Integrity Protection, and restarted my laptop again. My Dictionary app is still broken.

Update 3: I created a new user account and logged in with it to see if the dictionary worked. It was still broken.

  • Have you tried using the Dictionary app and seeing if you can set that up?
    – Natsfan
    Apr 30, 2020 at 22:46
  • Did you look in both Library folders? One at /Library and the other at ~/Library
    – Natsfan
    Apr 30, 2020 at 22:50
  • I started the Dictionary app, and in the bar at the top, the only choices are All and Wikipedia. I don't see most of the choices I saw before (English Dictionary, English Thesaurus, English-French, etc). If I look in the preferences, I see Wikipedia as the only source, like in my second screenshot. May 1, 2020 at 1:20
  • By ~/Library, I'm guessing you mean a folder called "Library" in my personal folder. I looked in it, both on my internal hard drive and in my last few backups, and none of them had a Dictionaries folder inside of it. May 1, 2020 at 1:24
  • 2
    @EliasZamaria, try to add other language to your selection, with an active internet connection - IIRC that would fill up the dictionary list. If that will not happen, then consider reinstalling Catalina, and do not mix with TimeMachine - in Catalina were a lot of changes.
    – Yoan
    May 4, 2020 at 6:40

3 Answers 3


I think it's worth trying a reinstallation of Catalina. I've reinstalled macOS countless times to solve odd issues like this and while it may seem extreme, it's quite safe and often the simplest and quickest option.

Make sure the machine is backed up, then restart into the Recovery partition by holding down Cmd-R at startup, then reinstall the OS. It shouldn't take very long and you can set it going overnight or another convenient time.

Your files and settings shouldn't be affected by the reinstallation, but backing up is always sensible in case of (very rare) errors.

If this doesn't work, as a last resort you can try a clean install, and then restore from Time Machine backup, being mindful of @Yoan's warning about mixing Time Machine backups.

  • I am sick of waiting for other answers. I am about to try the idea in this answer. May 5, 2020 at 17:05
  • I reinstalled Catalina and restarted my laptop, and it is still happening. May 5, 2020 at 18:59
  • Sorry I couldn't help. Given that an in-place reinstall didn't help I guess its unlikely a clean install would either. But may be worth a try as a last resort if you don't get a solution here or elsewhere. It just occurred to me that it could be a problem with your user account, so a troubleshooting option would be to test with a new user account and if it works migrate your files to it. But hopefully Manu can help you. May 6, 2020 at 18:23
  • I reinstalled Catalina again, just to make sure I did it right, and that didn't fix it. May 6, 2020 at 19:29
  • A clean install is different. You erase your system disk first and once Catalina is installed you installed from backup. But, as I said, that's a last resort. May 6, 2020 at 21:06

Follow the instructions given below if it doesn't help then do reply so we can work on this together

  1. Open Launchpad or Spotlight search Dictionary and launch the app
  2. When you are in the dictionary app open Preferences ( Command + , )

3.Tick on the desired dictionaries if they appear 4.If they don't click on file in menu bar when you are in the dictionary app and open dictionaries folder

you will see


Reply with its contents for further discussion...

  • When I click "Preferences", I see the list with only the Wikipedia item, just like my 2nd screenshot. I opened my dictionaries folder and it is 150KB and has a folder named "CoreDataUbiquitySupport" and nothing else. There are 2 folders within "CoreDataUbiquitySupport", named "Elias~61415B95-D49E-5617-9684-9B19FD70B26A" and "Elias~945512EF-5224-5A09-828D-BEE27229B569" May 5, 2020 at 20:23

I started my Dictionary app, and it started downloading the dictionaries I had before, and after that, it started working. I have no idea why this happened, or why it didn't work all the other times I started the app.

Edit: the Dictionary app works, but triple-tapping still gives me the "No Local Dictionary Available" error.

Edit 2: I restarted Chrome, and now the dictionary popup is working everywhere. I hope I fixed it for real now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .