0

Using dsenableroot I've just changed the password to a very simple one and terminal says

***Successfully enabled root user.

Then I run a command with sudo and it won't accept the password I just set. Tried setting different passwords and opening new terminals but it doesn't help.

What can be the problem and how do I even debug this?

2
  • Doesn't sudo take the current user's password by default? In order to do it as the root user you have to first be the root user. Apr 26 '20 at 16:40
  • sudo certainly doesn't need root enabled. Almost nothing on a mac requires root to be enabled… which is why it isn't by default. Best guess right now, root is not even in the sudoers list.
    – Tetsujin
    Apr 26 '20 at 16:42
1

You need to enter the password of the current user (who needs to be in the admin group unless you changed sudoers) if you run sudo.

PS: as other people already mentioned in the comments: you don‘t need to enable root to run sudo, basically you don‘t need to enable it at all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .