1

I haven't used pipenv since upgrading, but today I needed to work on an old project and I'm getting problems with pipenv and other python utilities. I did a xcode-select --install and brew update && brew upgrade and that didn't help. I ever tried brew bundle dump --describe --global && brew bundle install --global. Even a simple commmand like pip3 install sorteddict fails with

  Using cached sorteddict-1.2.1.tar.gz (5.2 kB)
    ERROR: Command errored out with exit status 1:
     command: /usr/local/opt/python/bin/python3.7 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/_2/qxtp7dds6r5df9q369cxlswm0000gn/T/pip-install-00izrc3z/sorteddict/setup.py'"'"'; __file__='"'"'/private/var/folders/_2/qxtp7dds6r5df9q369cxlswm0000gn/T/pip-install-00izrc3z/sorteddict/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /private/var/folders/_2/qxtp7dds6r5df9q369cxlswm0000gn/T/pip-install-00izrc3z/sorteddict/pip-egg-info
         cwd: /private/var/folders/_2/qxtp7dds6r5df9q369cxlswm0000gn/T/pip-install-00izrc3z/sorteddict/
    Complete output (5 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/usr/local/Cellar/python/3.7.7/Frameworks/Python.framework/Versions/3.7/lib/python3.7/tokenize.py", line 447, in open
        buffer = _builtin_open(filename, 'rb')
    FileNotFoundError: [Errno 2] No such file or directory: '/private/var/folders/_2/qxtp7dds6r5df9q369cxlswm0000gn/T/pip-install-00izrc3z/sorteddict/setup.py'
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
8
  • have you tried brew reinstall python or reinstalling any other tool that's causing errors ?
    – anki
    Commented Apr 26, 2020 at 15:33
  • @ankii didn't help. Commented Apr 26, 2020 at 15:35
  • can you check which file/ folder is actually missing in '/private/var/folders/_2/qxtp7dds6r5df9q369cxlswm0000gn/T/pip-install-00izrc3z/sorteddict/setup.py' ?
    – anki
    Commented Apr 26, 2020 at 15:37
  • @ankii Everything up to and including T is present. There are a shitload of pip-req-tracker-* directories in that directory, but no pip-install-* directories. Commented Apr 26, 2020 at 15:41
  • It seems pip still thinks that there's a setup file lying around. Let me see if there's a cache clearing command. You can check pip --help though.
    – anki
    Commented Apr 26, 2020 at 15:41

1 Answer 1

1

Looks like it's a problem with SortedDict. I can pip install other packages. I commented sorteddict and sortedcollection out of my Pipfile and I can start up my pipenv. (I was only manually installing sorteddict because pipenv wasn't working.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .