1

A few days ago I encountered the following problem: when pressing the spacebar to play an mp3-file from the desktop, I only heard the left speaker. Also through the headphones you only hear the left side. Now here comes the weird part: what you hear is a sum of the left and right channel of the stereo file! I made a file with a piano on the left and a bass on the right, and you hear them both from the left.

The strange thing is, that it only happens when QuickTime is playing the file. When I play the same audio through VLC, Logic Pro X or SoundStudio, it is in stereo.

At first I did all the obvious things. I checked the Audio/MIDI-settings, restarted, reset PRAM an SMC. Then I went to plan B: a complete rebuild. I formatted the disk and put back a TimeMachine backup. The problem persists. I did another new OS install, but now without formatting the drive, no change.

I tried everything I could come up with. The only thing I couldn't do was altering the routing of QuickTime/QuickLook with Terminal, because I don't know how to...

HELP!

  • TBH, resetting the SMC, PRAM and nuking & repaving the OS is a bit of overkill because other apps are reading this file correctly. If you have a copy of QuickTime Player 7 (not the new QuickTime Player v.10) the Window > Show AV Controls allows you to adjust Volume balance, bass, treble and pitch shift. QuickTime Player 10 is completely missing these functions. – IconDaemon Apr 26 at 13:21
1

If the problem only occurs in one application, then it's likely to be a problem with its settings, or some system setting that controls audio per-application.

Wiping the drive and then putting all the files back using Time Machine will leave you with an identical drive.

You may want to try deleting the file at:

~/Library/Containers/com.apple.QuickTimePlayerX/Data/Library/Preferences/com.apple.QuickTimePlayerX.plist

(i.e. in the User Library.)

... and then test the problem. If that doesn't work, you may want to restore this file to keep existing preferences.

| improve this answer | |
  • Tried it... didn't work. – Midicijnman Apr 26 at 17:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .