40

Home and End do nothing in iTerm2, nor do ⌘← and ⌘→.

However, Ctrl-A and Ctrl-E do work.

Can Home and End do this?

Preferences->Keys_Key Bindings in iTerm2 do not offer a "Start of Line" or "End of Line option.

Related: 1, 2

1

3 Answers 3

52

^ ControlA and ^ ControlE are keybinding in Bash and ZSH, not in iTerm (or Terminal).

If you want custom bindings within iTerm, you will need to bind the actual keyboard sequence in the keybinding. "Start of Line" and "End of Line" are descriptors, not the actual key strokes.

So, to do this you'd need to send ^ ControlA for Home via their Hex Codes. In this case, the codes would be 0x01 for "start of text" (^A) and 0x05 for "ENQ" (^E).

In the image below, you can add a new binding in Preferences → Keys → Key Bindings

  1. Click on + to add a new binding
  2. Click on Record in the dialog box
  3. Press your desired key (Home in this case).
  4. Select your Action (you can scroll or search). Select "Send Hex Code"
  5. Enter the Hex Code (0x01 for "start of text")
  6. Test it out!

iTerm2 Keybinding Home to ^A

2
  • 1
    Note: I'm trying to add some screen shots, but my Dell 104 key keyboard with the Home/End/PgUp/PgDn etc. buttons seems to have developed legs and a passion for ice cream as it apparently left the house. As soon as I get my keyboard back, I'll get some screen shots going.
    – Allan
    Apr 26, 2020 at 20:12
  • 2
    Thank you! One correction: 0x05 is End, while 0x03 that you gave is Ctl-C (break out of the line.)
    – Joshua Fox
    Apr 27, 2020 at 8:00
30

The accepted solution proposed by Allan is not optimal, as this keybinding affects *ALL* applications that are executed on the terminal and this key remapping would mean that some applications won't work as expected:

For example, if you use 'vi' then the keys 'Home' and 'End' no longer work after this key binding (those keys work ok if you don't do the proposed key binding)

A better solution is to do the key mapping on the shell itself:

In zsh (the default shell being used by macos nowadays), just add this in ~/.zshrc:

bindkey '\e[H'    beginning-of-line
bindkey '\e[F'    end-of-line

and Home and End keys will work ok in both the command line and vi

4
  • 4
    This is the optimal solution!
    – dpwrussell
    Aug 29, 2021 at 17:26
  • While you said about remaping for all apps is true the bindings you have provided does not work. Mar 9 at 17:10
  • 2
    This should be the accepted solution!
    – Claudiu
    Apr 12 at 20:48
  • 1
    Works like a charm, thanks! May 6 at 15:44
0

I had a similar problem, except in my case home/end was moving me to the beginning/end of the scroll buffer, not to the beginning/end of the line in the shell. The 'bindkey' solution above did not work, but I found that when I disable "Page up, page down, home and end scroll outside interactive apps" in profile's "Keys" tab, it starts to work as I expect it to.

screenshot from iTerm2 settings

1
  • Thx but this is not an answer to the question in the original post. If you think it is still worth sharing, the best would be to post a question towards it and answer it yourself and then delete this one.
    – Alper
    Aug 6 at 8:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .