I have turned on the 'Auto deletion' option in iOS which will remove an App from my phone if it is not frequently used.

The screenshot shows how the home screen looks on my phone. The icloud download icon mean the app has been offloaded.

I find this feature very inconvenient but now I am unable to find a way to disable it.

enter image description here

Once it is activated the option disappeared

enter image description here

How can I stop the auto offload?

1 Answer 1


This is in the settings app in two places by default:

  • Offload Unused Apps

You can search settings or just do a spotlight search system wide to go right to the place where this is set. (It’s under General and iPad/iPhone storage)Offload Unused Apps

If you don’t see it there, head over to the 'iTunes & App Store' section of the settings app and scroll the content up to look for the same toggle at the bottom of the page. Tap it to disable the opt in for this setting.

App Store settings for Offloading unused apps

  • The option disappeared once you activate it. Commented Apr 25, 2020 at 23:44
  • @AnthonyKong I’ve edited this to have a second place. Since I don’t enable this, my search didn’t find it (or search can’t find that at all - I would file a bug/feedback if your device doesn’t find that setting - seems like search should get you to it IMO)
    – bmike
    Commented Apr 25, 2020 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .