0

My laptop (mid-2012) won't boot past the Apple logo. Safe boot won't work either.

Disk utility in recovery mode and fsck in single-user mode both say the hard disk is fine. Verbose mode report has several lines of disk1s1 I/O error, however.

This machine apparently does not have the diagnostic tools on it, as booting while holding down the 'D' key takes me to Internet recovery. I tried that to see if the online diagnostics would run but it gets stuck on the spinning globe screen after I enter my wifi password.

I'm thinking this could be the hard disk, the hard disk cable, or the main board. How do I tell for sure so I don't spend money unnecessarily?

1

Your thinking is correct. It’s likely the hard drive, however it could also be SATA cable. Given that it’s inexpensive, it makes sense to charge it out with the replacement drive.

However, to know for certain, connect your drive to a USB to SATA adapter, if the drive works properly, then you have proof positive it’s the cable.

Doing diagnostics on a drive with an “unknown” working Component could give you erroneous results.

| improve this answer | |
  • Thanks. The SATA cable ranges from $20 on eBay to $80 from iFixit (Australia). If it turns out the cable is bad are all cable replacements created equal or does 'you get what you pay for' apply? – jcm Apr 26 at 4:45
  • 1
    IFxit is pretty pricy. The ones I’ve bought on Amazon and eBay have all worked with no problem. To date I think I’ve bought just under 100 of them in total. The only time I had to return is because I got the wrong one. – Allan Apr 26 at 6:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .