Whenever I remove my headphone, my MacBook pro mid 2012 (macOS Mojave, 10.14.5) defaults to "Digital Out — Optical digital-out port" (and the port is usually "red" -digital out light), but sometimes it doesn't show it [usually when sound is not playing]) which is not OK since it should be "Internal Speakers — Built-in".

enter image description here

I've tried these terminal commands and they don't work.

sudo pkill coreaudiod
sudo killall coreaudiod

Are there similar commands to redirect the automatic "Digital Out" setting?

The only fix I found so far for that bug, is to blow air inside the jack for ~5-10 seconds and then I have access to my speakers again... weird.

  • 1
    Does this answer your question? Why are my Macbook's internal speakers not available? BTW, it's not a 'bug' per se, it's a physical connectivity issue, dust or dirt in the contacts.
    – Tetsujin
    Commented Apr 23, 2020 at 16:15
  • Indeed, it might not be a "bug" per se, but there might be a software solution to "go around" the "digital out" problem. The toothpick has never worked for me. Only the blowing air into the plug. I'd like to have better control of the jack from the terminal. Commented Apr 23, 2020 at 17:29
  • This question is: "Can I force to use", not "why it doesn't show". I'd like to have a command (if possible, hence the "can I force") that would force the computer to stick with only one option. If the answer is "there is no command", then it's the answers. Commented Apr 23, 2020 at 17:47
  • 1
    Your asking your service garage to fix the car horn because your brakes have failed… why not tackle the actual issue?
    – Tetsujin
    Commented Apr 23, 2020 at 17:52
  • 1
    @Tetsujin is spot on with this. The physical switch inside the port is broken and needs to be fixed. See apple.stackexchange.com/a/228253/119271 for more info.
    – Allan
    Commented Apr 23, 2020 at 18:04


Browse other questions tagged .