0

I've searched the more-recent threads and cannot seem to find a solid option. Does anyone have a good clipboard app with history that doesn't screw up the clipboard and require a restart? Alfred and Quicksilver sometimes do a decent job. I do not have the pro pack for alfred, btw, but I have used quicksilver for 15+ years and don't want to buy alfred for one purpose if everything else is solid with quicksilver. If it becomes the only option, then I might have to.

on top of several that I've previously deleted, of those still in my apps folder, I have tried:

  1. clipbuddy
  2. clipmenu
  3. clips
  4. copyclip
  5. copyless 2
  6. corkboard
  7. flycut
  8. iclip
  9. isnip

my main problem experienced with most of these in recent months especially, is that images don't get held in them, nor do they actually get accepted into my system's clipboard either. for example, I very often take screen captures of portions of my screen or just one window only to the clipboard so I can paste it elsewhere. now, most of the time they don't appear in my clipboard. too often, the last image I copied prior (usually a lasso portion from either preview or photoshop or affinity photo) will get "stuck" in my clipboard. it's gotten to the point where I've removed all the third-party managers and might try to work with quicksilver, but something that has a dedicated interface would be ideal. I think $30+ for the alfred powerpack just to test if it'll work properly is a bit steep. I don't mind paying for good software, but there's only one feature I need and I cannot tell if it'll work now or continue to later. any recommendations MUST work with both text and images or lasso segments of images that have been copied, or at least allow the main clipboard to still properly handle those images outside of the clipboard manager app.

I'm not sure if it'll matter with your suggestions, but it should be known that because of a few legacy apps, I won't be going past 10.14.x for the foreseeable future. I don't know if it's an issue based on 10.14 as I don't recall the apps having issues like the one I have now long ago, just that I didn't like the interface of most of them.

1

I can confirm, Alfred does the job.

To be sure, I double checked by testing its clipboard functionality for your requirements: partial (lasso) screenshots, fullscreen screenshots and image files. Everything works fine and shows up just as expected in Alfreds clipboard manager. Pasting inside a document works, whereas saving the screenshot from clipboard into a file using finder, doesn't work. But this is normal behavior. That said, I'm running MacOS 10.15.4 and Alfred 4.0.9 with Powerpack.

If you want to try further alternatives, you could try Copy'em Paste, Clipy and Keyboard Maestro.

2
  • 1
    Thanks @youngpilot. I'm going to give Copy'em Paste (CemP) a try. I appreciate the response. I have used quicksilver for so long that switching to alfred for the purpose of an expensive clipboard manager seems like a waste. if I know that CemP works well for my purposes I'll run with that. I don't mind $15 for something that does a solution quite well. it'll save me that in time in no time. if alfred wasn't duplicating most of the other functionality, I'd go with it. I set a reminder to mark your comment as the answer in a few days, I just want to get add'l feedback in the meantime. thanks! – Jeremy May 13 '20 at 22:05
  • 1
    So far, Copy’em Paste has worked very well while I tested it. Well worth paying half the price of Alfred for the set of features I need. Thanks again @youngpilot! – Jeremy May 28 '20 at 20:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .