I have a 2015 MacBook Pro in front of me that had an issue with water being spilled on the keyboard. As a result of this, it was reported to me that the main issue was it appeared as if the shift key would intermittently press even when it was not. As a result it is impossible to login in as random shifts are occurring making it impossible to enter the correct password.

I tried plugging in an external circa 2011 iMac wired USB keyboard I had, but at the login screen nothing happens when I type on it. I tried plugging it in before powering up, once I have gotten to the login screen, and in all the available USB (A) ports.

I tried resetting the PRAM but holding down command+option+p+r before the screen comes on doesn't seem to do anything, it just boots up normally. The same thing with command+s for single-user mode or command+r for recovery mode.

I was able to reset the SMC but this just dumps me to a screen where if I say "My keyboard isn't working when typing my password to log in" it tells me "if you were unable to use your keyboard to type your password it may not be compatible with file vault". It then wants me to enter a password to disable file vault, which of course if I could do I wouldn't need to be here in the first place.

How can I log in using the external interface? I tried searching for what keyboards are compatible with file vault but just got results about disabling it, which in unhelpful. Other answers simply suggest a USB keyboard should just work. Since it's an Apple keyboard I expected it to just work.

Update: Is there some way to reveal the characters I am typing into the password field? If I could see what I was typing, I could keep trying on each character until the case was right. Or, if I could get it to actually show me my username instead of dots I could enter it there and try to copy it to the password field or at least get an idea when the shift key might be working.

1 Answer 1


You need to replace the MacBook keyboard.

(Or at least disconnect it from the logic board)

The problem is you have two keyboards "battling" it out for what keys get pressed. The top case assembly which consists of the track pad and the keyboard are both USB devices. You can have several of these devices plugged in simultaneously - in fact, I have 3 keyboards and one mouse (2 keyboards are for macros) and the iMac happily accepts input from all three simultaneously.

What's happening is you're keyboard is still plugged in and the ⇧ Shift key is acting like it's being pressed because the contacts are shorting out. I wrote a lengthy answer on this very topic: Keyboard key stuck or not being recognized; how to fix. So, even though it's a different keyboard, you're Mac doesn't know; actually it doesn't even care. It's going to process each key press as if you wanted it that way.

You're only (temp) solution is to disconnect it from the logic board. There's no amount of resetting the NVRAM and/or the SMC, re-installation of the OS, etc. is going to bypass a physical problem.

You have a liquid damaged MacBook which means there's probably much more damage - like corrosion of the electrical contacts - that you're going to have to contend with. Take it in for service!

Below is an image from iFixit.com showing the location of the keyboard connector. Disconnect this to get your external keyboard working again. You will need a mouse or another track pad.

2015 MacBook Pro Keyboard Connector Location

  • I’ve seen a spill break the keyboard or short power. Disconnecting the internal KB works in less than 10% and most of those fail anyhow within 90 days of when you disconnect in my experience. apple.stackexchange.com/questions/354061/…
    – bmike
    Commented Apr 21, 2020 at 19:21
  • 1
    The disconnect is just temporary - the ultimate fix is to take it in.
    – Allan
    Commented Apr 21, 2020 at 19:26
  • Sadly, "taking it in" isn't an option currently, and Amazon is quoting a 5 week lead time for the tools I would need to open it up myself. And this is for a machine that is being used for "work at home"...
    – Michael
    Commented Apr 21, 2020 at 22:26
  • Well, low tech fix for now... i popped the shift key where the spill occurred and pushed the plastic tip of a pen lid between the plastic connector and the metal beneath i was able to log in! Other than having to press the Option key a bit harder than normal and one non-functional shift key (now when I press it I get weird characters like left Shift+k gives me an apple symbol) everything is working for the time being!
    – Michael
    Commented Apr 21, 2020 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .