I have a 15" 2019 MacBook Pro and a LG 34BK95U monitor (business version of 34WK95U - same hardware, longer warranty).

The correct resolution of the monitor is 5120x2160 and sometimes everything works at that resolution. But, sometimes when I connect my MacBook (via ThunberBolt 3) or when it wakes from sleep already connected, it sends a 3440x1440 image to the monitor, which looks fuzzy and gets a warning from the monitor about the incorrect resolution.

When this happens, the MacBook doesn't even give me the option of using the correct resolution in system preferences - even if I Option-click on Scaled, the highest resolution available is 3840x2160. This makes me suspect it's using DisplayPort 1.2 instead of 1.4, because I believe that's the maximum resolution DP 1.2 supports.

Sometimes disconnecting and reconnecting the cable fixes it, sometimes switching to a different TB3 port in the MacBook fixes it, sometimes rebooting the MacBook or the monitor fixes it, but nothing reliably fixes it, and sometimes I go through all of the above and still have the wrong resolution. (To reboot the monitor, I just unplug it from the wall, wait a few seconds, then plug it back in.)

I mainly use the ThunderBolt 3 cable that came with the monitor, but I also tried a short passive TB3 cable - same results.

It also forgets the arrangement of the display relative to my MacBook's screen when using the wrong resolution; it remembers when it uses the correct resolution.

In 🍏 > About This Mac > System Report... > Graphics/Displays, it has the display connected to the Radeon Pro 550X with the following info:

  Resolution:   3440 x 1440 (UWQHD - Ultra-Wide Quad HD)
  UI Looks like:    3440 x 1440 @ 60 Hz
  Framebuffer Depth:    30-Bit Color (ARGB2101010)
  Mirror:   Off
  Online:   Yes
  Rotation: Supported
  Automatically Adjust Brightness:  No
  Connection Type:  Thunderbolt/DisplayPort

I'm currently on macOS Catalina 10.15.4, but this also happened on previous versions, including Mojave releases.

It also sometimes turns on HDR mode when using the wrong resolution, which just has the effect of making everything a little darker. I think that started with the Catalina update.

After reading Incorrect external monitor resolution detected, true resolution not available I went into the Color Sync Utility and Verify found one issue, but Repair couldn't fix it:

Searching for profiles...
Checking 35 profiles...
   Header message digest (MD5) is not correct. 
   The file is locked. Could not be fixed.
Repair done. 0 out of 1 profiles fixed.

I also noticed that under Profiles > Computer > Displays there are 4 different "LG HDR 5k" entries. Not sure if that's related or not.

After reading External monitor has wrong resolution I tried resetting the NVRAM / PRAM, but that didn't fix it either.

I also have a Windows PC connected via DisplayPort and it always works at the correct resolution.

Update: It seems to be getting worse. I've only been able to get the correct resolution once since posting this. And it went away as soon as the computer went to sleep.

I tried connecting a CalDigit USB-C Pro Dock (which is actually Thunderbolt 3, despite the name) and then connecting it's DisplayPort output to the monitor. The port on the dock is labeled 4k, but it can actually output the full 5120x2160 resolution - but only at 30hz. The low refresh rate is annoying but better than the fuzziness of 3440x1440@60hz, so I'm going with it for now. There were a couple of times where I had to disconnect and reconnect the DisplayPort cable to get any image out, but one re-connection fixed it each time, making it far more reliable than the direct TB3 connection.

I've also ordered a generic USB-C to DisplayPort cable, so I'll update again after I've had a chance to try that.

Update 2: USB Type-C to DisplayPort cable behaves about the same as the dock - correct resolution, but only 30hz refresh rate.

Update 3: I got a hold of a Windows laptop with thunderbolt 3, and it worked perfectly on the first try, and again after I disconnected it and reconnected it. So I think that points to a problem with my MacBook.

Update 4: I now have a 2021 16-inch MacBook Pro with an M1 Pro chip. I switched the display back to DP 1.4 just to see if it would work, but it has the same symptoms as the older Intel MacBook. So, I'm back to DP 1.2, which usually works.

(Occasionally the monitor will freeze when I wake the computer up, and the last time I rebooted the monitor to unfreeze it, the laptop crashed and rebooted as soon as the monitor came back on...)

Update 5: I tried installing LG's "OnScreen Control" app and under monitor settings, it had a software update "Run" button that appears to have updated the monitor's firmware and resolved some of the issues. I went from (3.11, 0, 2.4) to (4.12, 16, 4.17), and I was able to switch back to DisplayPort 1.4 and get the correct resolution on the first try. I'll try to remember to post another update in a few months.

Update 6: No further issues since updating the monitor firmware; it's been working well for over a year now!

  • 1
    Try this in Safe Mode so that you can be sure that third party programs aren't tampering with the ability to use the correct resolution.
    – Todd
    May 8, 2020 at 15:54

1 Answer 1


i have got this same problem. by setting monitor to displayport version 1.2 i was able to run it in native resolution (5120x2160) in 60hz without major problems.

initially when i got the monitor out of the box i was able to run it in native resolution using display port version 1.4. then i installed LG's OnScreen control app on my mac, updated the monitor firmware using the app, the monitor started behaving as you described in displayport 1.4 mode. see the screencaps under about what resolution monitor supports in 1.4 mode and what firmware version im running.

available resolutions in 1.4 mode monitor firmware version

LG support said that this is mac driver problem. i have got no idea how to install any drivers.

macbook pro 13" version 11.0.1 (big sur) late-2019 Intel Iris Plus Graphics 655, 1536 mb

im using the DP cable which came with the monitor.

  • Thank you! That did it! I've disconnected and reconnected 4 times and it used the correct resolution each time! Nov 30, 2020 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .