Bought a new Macbook Pro 13 Inch 2019 with touch bar. It came with Mojave, I upgraded to Catalina after initial setup. Touch bar was working fine before and than after installing some applications, I noticed the touch bar disappeared and it was dark black. I did SMC reset and everything and it didn't came back. So I did Factory reset by erasing the drive and installing back OS. After erasing Catalina was the again the OS and touch bar didn't came back. I tried to start the processing again of factory reset again with the process to reintall OS that came with the device but again it showed me to reinstall Catalina instead of Mojave so I did this and again there was no touch bar. I tried to search for Touchbar in running processes and its not there. Can anyone please advise what could go wrong and if there is a solution for this?

  • If you have to keep "factory resetting" then there's a bigger problem. When you said you "search for Touchbar in running processes" what exactly did you search for?
    – Allan
    Commented Apr 20, 2020 at 12:51
  • @Allan I just types "Touch" and there was no process running on activity monitor. I have one more exactly similar device and when I search for it gives me "TouchBarServer". The second device is running Mojave Commented Apr 20, 2020 at 12:58
  • Go into terminal and type the commands sudo pkill "Touch Bar Agent" and sudo pkill ControlStripAgent. That will reset them. To see if they are running, type ps -A | grep -i "touch bar agent" and ps -A | grep -i "controlstrip"
    – Allan
    Commented Apr 20, 2020 at 13:07
  • @Allan just did this again based on your advise. used both pkill commands and than ran command to see if they are running I see 548 ttys028 0:00.00 grep -i touch bar agent 550 ttys028 0:00.00 grep -i controlstrip And touch bar is still black Commented Apr 20, 2020 at 13:13

2 Answers 2


The Touch Bar on Apple's MacBook Pro line of laptops is a capactive touch display not unlike the screen in an iPhone; it's just much longer and thinner. This means it's susceptible to all of the same ailments that plague every other touch screen display - cracked/broken LCD, touch no longer functioning, blank display, etc. Some are obvious (i.e. a cracked screen) and others not so obvious; like a blank or non-responsive screen.

In this case, a blank Touch Bar could be either software or hardware. So, to determine what the issue is, you need to go through a process of elimination.

  • Eliminate software as the cause. (See link for steps). The idea here is to get to a "clean" environment by eliminating as many 3rd party apps, kexts, configurations, etc. that could be causing an issue. You want to follow these steps so you don't go through the trouble of reinstalling macOS. There's no point in expending the time, effort and risking data for something that won't work. Booting into Safe Mode or Recovery Mode has the same benefits of reinstalling without the extra hassle.

  • It's likely hardware. There a very good chance that the hardware has failed in some way. It could be the display itself, the driver (not software), or even the T1/T2 chip (drives the Touch Bar). Unfortunately, there's no easy DIY way to diagnose it. Since the entire top case assembly must be disassembled to get to it, the usual fix is just to replace the top case with a new one.

    Bottom line, it needs to go in for service.

Note: the fingerprint reader (Touch ID sensor) is located adjacent to the display and both are behind a single pane of glass. It's not uncommon for folks to believe that the Touch Bar must be working because Touch ID still works. No; they are two completely different components, but since the T1/T2 chip handles security, it's a good bet that the chip is not at fault for the ailing Touch Bar.

  • Thanks @allan for the detailed response, unfortunately it looks like in my case its the hardware failure. I have tried all software fix even reinstalling macOS with the default version the device came with, all failed. Commented May 15, 2020 at 0:18
sudo pkill TouchBarServer

link to a similar question

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .