1

I normally share my MacBook Pro 13 2018 (on OSX 10.15.4 Catalina) internet wifi connection to my iPhone XS Max connected directly with a usb c to lightning cable. But now it stopped working and I see that Iphone USB doesn't appear anymore in the "To computers using:" box.

I tried the solution offered here that says that I should add an new location under the network preference, with no avail.

I also checked the solution offered here but the answer I don't understand why suddenly I would need content caching to share my internet connection.

Bluetooth sharing works, but the speed is very slow. Belkin usb-c lan, thunderbolt bridge and usb 10/100/1000 lan do not work. I was wondering if my cable was the cause, but the iPhone appears in the finder and charges without problem

How do I get the iPhone USB to appear back in the sharing tab and resume internet sharing? Below find screenshots of my settings with my iPhone connected to the laptop.

Sharing setting: enter image description here

Network Setting: enter image description here

1

sorry for the short answer but simply, your interface for iPhone USB is not there. To add it back, Go to Network Preferences and then click the Lock icon and enter your password. Then, click the "Plus" icon at the bottom. This will present you with a few choices. See if you can choose iPhone USB.

If that doesn't work, then open Finder and see if the device is recognized. If it is recognized, then that means that you might have a problem with the charging cable or something like that.

The best options would be to update to the latest iOS and macOS on your devices and then try using another charging cable from Apple. You can also use Safe Boot to check your Mac for issues. See this for more on Safe Boot: https://support.apple.com/en-us/HT201262

Good luck!

1
  • Unfortunately none of this worked for me – Nanoboss Apr 22 '20 at 9:20
1

(Might be specific to the "computers using" adapter being USB interfaced.)

My problem started when I created a bridge in the network preference pane, then added the USB ethernet adapter (which is the one the connection is shared with) to this bridge. Despite that I had after deleted the bridge and seemed to have restored the network config to what it was before my bridge test. In the end, here's how I fixed it, it may help, bridge or not in your scenario:

  1. Disable the connection sharing
  2. In network pref pane, remove the USB ethernet adapter from the network (the minus sign)
  3. answer 'yes' I want the adapter to return next time it's connected
  4. 'apply' in the bottom right
  5. unplugged/replugged the USB cable
  6. Re-do the "connection sharing" config
2
  • When you say the USB adapter, you mean the Belkin usb c? Because it's something that was always there, even if I never used such a device. – Nanoboss Apr 22 '20 at 9:21
  • I personally have a usb/hub wEthernet on it, and a usb-c vantec docking (also with Ethernet). "Belkin USB C" always there... I have not observed this on my macbook. It could be a delkin usb-c docking you plugged once, and it created a named ethernet adapter. – Jeff Dag Apr 24 '20 at 17:32
0

I have a Mac mini (2018) running MacOS 10.15.6 (Catalina) and tried to share internet through USB to my iPhone SE 1st Gen. On the Sharing Preference I have the the Internet Sharing on and the iPhone USB box checked. In Content Caching I have the Internet Connection box checked. The internet did not share to my iPhone SE when plugged in through the lightning cable. Another post recommended that I open a Finder window and click on my iPhone, and then allow the Mac mini and iPhone SE to "trust" each other when prompted. That seems to resolve the issue and internet worked through USB no problem. The iPhone USB box on Internet sharing did disappear once before I learned of the trust step and then the USB port stopped working altogether until I restarted. The Content Caching never works but the internet sharing through USB is fully functional at this time.

0

Found a beginning of answer.

It seems that something weird is going on if you iPhone isn't connected to the internet through cellular. My data plan was over at the moment I tried to get the share the wifi of Mac to my Iphone. When I resumed my data plan, I could again use the wifi sharing and put my iPhone on airplane mode.

Everything is happening in a black box so I can tell the source of this issue.

0

Same issue happened to me, it stopped working since I updated my Mac to Mojave(10.14.6). Internet sharing from Thunderbolt Ethernet to WiFi ends up with no internet.

I found a solution only recently. Here is the workaround I found, I installed Fiddler from Telerik, make it act as a proxy. And from mobile device, enter my PC's IP address and port from Fiddler. I can share LAN connection to my mobile device.

 t

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .