5

One of my contacts with whom I exchange iMessages, has started showing ⌛︎ Preview Hidden in the macOS Messages app just below their name.

enter image description here

Interestingly, this is not shown in the Messages app on my iPad and iPhone, just the Mac. Also, I have not enabled Hide Alerts for the said contact. I am able to communicate with them normally, and I also receive the notifications for any messages that they send.

My questions are:

  1. What does ⌛︎ Preview Hidden mean?

  2. What causes it to get enabled?

  3. How to remove/disable it?

  4. Does it apply to all the devices linked to my Apple ID and where Messages are enabled?

I use Messages in iCloud, and I am running current up-to-date version of OS on all the devices that I use (macOS Catalina 10.15.4 (19E287) on Mac and iOS/iPadOS 13.4.1 on iPhones/iPads).

4
  • 1
    On the bright side, you aren't the only one. Someone on the Apple Forums posted a similar question last week. – Rushil Srivastava Apr 19 '20 at 7:32
  • 1
    By any chance, do you have Parental Control or Screen Time settings enabled? This contact may be setup as a "Restricted Contact". – Rushil Srivastava Apr 19 '20 at 7:33
  • @RushilSrivastava No and no. – Nimesh Neema Apr 19 '20 at 7:38
  • @RushilSrivastava Thanks for sharing the link to Apple Support Communities. – Nimesh Neema Apr 19 '20 at 7:39
2

I had this too and this seemed to give me what I wanted (the preview): System Preferences->Notifications->Messages->Show Notification Preview->set to Always. Then Quit Messages and restart.

1
  • Wow. My "Show nofications preview" preference is only a checkbox in 10.15.4. So, I should interpret that preference to mean "do not show a preview and don't show any messages either". Big a** eye roll. – Jeff Holt May 28 '20 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .