0

I have installed the open-source Blackhole driver on MacOS High Sierra and have set BlackHole 16ch as both the Input Device and Output device (e.g. via Option+click on the volume icon in the mac top navigation bar).

With this setup when launching QuickTime Player > File > New Screen Recording clicking the chevron now allows selecting BlackHole instead of the microphone, and the captured recording uses the better quality audio directly from the sound card rather than the microphone.

QuickTime Player screen capture

The problem is that while recording there is no real-time audio output via the speakers.

Tried adding a Multi-Output Device in the ootb Audio MIDI Setup.app (it appears in Spotlight if you type audio) and enabling both BlackHole and Built-in Output as shown in the screenshot below, and then selecting the Multi-Output Device as an Output Device in system sound settings (or via "Use this device for sound output" in Audio MIDI Setup), but then there is no sound from the speakers and the soundcard audio does not get recorded.

![macos audio midi setup app Multi-Output Device

Is it possible to both record the soundcard audio and output it in real time to the speakers?

NOTE: the audio I need to capture is not from the microphone but from an app.

  • The 2nd picture doesn't show the multi-out as selected for output. The speaker icon is on built-in. [I've never used Blackhole, & haven't used Soundflower in many many years, so I'm a bit rusty as to how they used to route, after Soundflowerbed stopped working.] – Tetsujin Apr 18 at 14:03
  • @Tetsujin: my bad; I had Multi-Output enabled, but when I took the screenshot it was not enabled anymore. – ccpizza Apr 18 at 14:50
  • OK, no worries… unless it's toggling itself back each time?? – Tetsujin Apr 18 at 14:52
  • 1
    it stays on as expected; i updated the screenshot – ccpizza Apr 18 at 15:15
0

The steps below are for BackgroundMusic, another open-source driver which works pretty much the same as Blackhole. The same steps have also been verified to work with BlackHole.

  1. In the Audio MIDI Setup.app create a Multi-Output Device and select the checkboxes for Built-in Output and Background Music.
  2. Option+Click on the top-right speaker icon in the Mac menu bar and under Input Device select Background Music.
  3. Under Output Device select Multi-Output Device as shown below.

    MacOs set input device

You'll notice that after setting Output Device: Multi-Output Device the volume slider and the volume control keys won't work anymore. BackgroundMusic adds a menu icon in the top bar which you can click and use the volume slider in the dropdown that appears.

enter image description here

Both BlackHole and BackgroundMusic seem to cause occasional crashes of the Audio MIDI Setup app, and are not yet 100% stable and reliable (at least not on the MacOS version I tried), but they do work.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .