I'm having multiple issues with my 2008-model MacBook Pro. I took it to the Genius Bar and they suggested an Archive & Install, which I did. But now I have a new issue.

I have the wireless/bluetooth Apple Magic Mouse and Wireless Keyboard. Since the Archive & Install, neither is working properly. The mouse tracks and clicks, but the "touchpad" features like scrolling and swiping don't register at all. Also, the function key on the wireless keyboard doesn't seem to do anything.

If I go to the System Preferences and select Mouse, then "setup Bluetooth Mouse" I get a "Searching..." and a spinning wheel forever. The mouse is paired but I can't configure the Magic features.

Similarly for Keyboard. It's paired, and I've clicked "Use all F1, F2, etc. keys as standard function keys" so that if I want to use the keyboard to change the volume or something I should be able to use the combination Fn-F11. But both F11 and Fn-F11 do an Exposé thing. If I click "Set up Bluetooth Keyboard..." I also get "Searching..." and the eternally spinning wheel.

If I go to the Keyboard Viewer I see a keyboard layout that looks like the wireless one, but as soon as I press a key the Keyboard Viewer changes to a layout that looks more like the extended keyboard. Pressing Fn changes the keycaps on the ⌫ key to ⌦ , and the arrow keys change, too, but actually pressing these key combinations doesn't do what it says it will do: Fn-⌫ and ⌫ are doing the same thing.

Casting the "put to sleep/wake up" and "restart" spells don't seem to have any effect. Any clues?

  • Have you tried creating a new blank user to see if the user exhibits the same behavior? Nov 11 '10 at 21:40
  • @Martin: Thanks for the suggestion. A blank user has the same problem. Nov 15 '10 at 13:59
  • ....."Spell".... Really?
    – Fake Name
    Nov 17 '10 at 8:30
  • @Fake It took me a while to realize what you were talking about… then I realized that he… “casted a spell”. Oh my… ;) Nov 18 '10 at 21:57
  • @Martín Marconcini - I figured out what he meant immediately. That does not mean it isn't a terminally stupid way to think of how computers operate, though.
    – Fake Name
    Nov 22 '10 at 5:18

The "software update" spell solved it. I had a number of updates come down last night and everything seems to work now.

  • You may accept your own answer if this solved your problem.
    – Besi
    Sep 28 '18 at 19:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .