0

I have a Mac Mini late 2012 running MacOS Catalina (10.15.4). I have a weird issue with drag and drop in Finder. When I drag a file/folder into a new folder to move it there, it does not let me hold down the mouse and navigate through the subfolders. I can drag and drop "one folder deep", but Finder does not open the folder that I drag on top of.

For example:
Finder Window
In this case, I could drag the "Database" folder into the "System Admin" folder" (Whoops that name lol) but not into the "Linux" subfolder inside "System Admin". Finder will only let me drag "Database" one folder deep. It will not open the "System Admin" folder and show me the subfolders where I could then drag on into "Linux".

I'm not exactly sure long this has been like this, since I usually use other methods than drag and drop to get stuff done, but I think that it has been like this since I upgraded from High Sierra to Mojave.
I am using the Magic Mouse 2 if that helps. I have been using is ever since I got this mac though, back when drag and drop still worked fully. And if I use other mice the problem is still there.

Any help is welcome!

  • If I'm understanding you correctly, you have to click, hold, drag to folder and keep holding the click until it shows the contents. Repeat until you get as far as you want. IMO, the Magic Mouse is horrible for this - get a proper mouse and it'll be easier! Just tested in Catalina so the feature is still there. – Allan Apr 17 '20 at 21:51
  • @Allan I have tried with several different "real mice", including a Logi G602 USB wireless gaming mouse. No luck. I am holding the click down for at least 10 seconds, nothing is happening. I am not getting that little green "plus" sign either when dragging to a different folder. It's weird because drag and drop is still working to some extent. – Noah Broyles Apr 17 '20 at 22:49
  • If you're not getting the little green plus, that means you can't copy it to that destination. First, try this in your documents folder with some test files. You can create them by issuing the command touch test1.txt test2.txt test3.txt and mkdir folder1. (make sure you're in Documents first - cd ~/Documents). If you can click and drag there, it's a permissions issue – Allan Apr 17 '20 at 22:56
  • I did as you said. Dragging and dropping moved the files just fine, however holding my click down over folder1 did not open folder1 and I still did not get the green plus. – Noah Broyles Apr 17 '20 at 23:00
1

So what worked for me was to turn on Spring-loading delay in System Preferences > Accessibility > Pointer Control.
System Preferences Window

I have no idea why it would not work without this, but it works fine now. Well, almost fine. I still do not get the little green plus sign when dragging files to a new location, but I am able to drag through into subfolders.

  • 1
    I think it is quite normal that you could not have folders opening automatically in the case you have described because this is exactly what this setting is for. See this Apple support page for a description of Spring-loading delay. You may not have had this problem before because this setting is (normally) enabled by default. – Alper Apr 18 '20 at 2:16
  • Yes @Alper I think you are correct! I came into the Accessibility settings a while ago and messed lots of things up. – Noah Broyles Apr 18 '20 at 13:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .