0

I reinstalled Catalina and everything works just fine with installation. but I am stuck at here and the setup assistant doesn't show up after the installation. I tried I Cloud account and I tried also the old user password enter image description here

0

2 Answers 2

1

This is completely normal. This is a macOS setting that some users prefer because it might provide more security. Do you remember the Username of your user when you were on Mojave (Or High Sierra)? If so, that is your username in the "Name" field. Password is the password to that user.

If you don't remember your creds: If you don't remember your login information, you can try using macOS Recovery to find out. First, boot macOS Recovery by restarting and pressing Command + R. Next, access the Terminal. If you had your disk encrypted, then first, you would need to type diskutil unlockVolume diskID and type the password of the disk. Then, type diskutil mount diskID. Then, you can do cd /Volumes/VolName/Users and ls. This will show you all users on the Mac.

Good Luck!

6
  • Thanks I needed to delete. Applesetupdone to get the setupassistant again becuaee there were no any admin. But now I am afraid if that means the I have 2 os on my Mac
    – Amr
    Apr 17, 2020 at 23:04
  • You can check by seeing if there are 2 Macintosh HDs. Also, for future issues, you can also try using sudo dscl . -create from Single User Mode to create a new user.
    – Todd
    Apr 18, 2020 at 23:18
  • I created a user with assistant manager. But you mean checking dublicate of HD in disk utility?
    – Amr
    Apr 19, 2020 at 5:49
  • Well actually, having two instances of macOS means that you have two disks with one instance each. That might tell you if you have two instances of macOS. The sudo dscl . -create was a suggestion should you run into the problem again.
    – Todd
    Apr 19, 2020 at 6:06
  • I just have one Mac HD so I think I have one Mac OS because I just reinstalled Mac OS. And reinstalling Mac OS doesn't dublicate
    – Amr
    Apr 19, 2020 at 6:08
0

https://apple.stackexchange.com/a/324521/371580 This helped me alot. If you resintalled on existed Mac OS most probably setup assistant will not show up. If this was the problem Delete .setupassistantdone from recovery terminal search for it and delete it then everything will be okay. Find more details with steps in this answer

Not the answer you're looking for? Browse other questions tagged .