0

I'm trying to install Windows 10 in BootCamp on my 2012 Macbook Pro, running mac OS Sierra, but fail to boot from the USB drive on which the Windows install tools reside. The error message I get is No bootable device -- insert boot disk and press any key.

What I did so far:

  • Tried to create a boot medium using Boot Camp assistant. This failed, because on the ISO-Image I have there is a file install.wim, which is too large for a FAT32-formatted drive.
  • Tried to manually create the boot medium, using the above ISO-image, formatting the drive using ExFAT. This resulted in the above error message. I did some research and it seems that ExFAT is not bootable?

The most promising attempt was the following:

  1. So, since I have another device running Windows 10 available, I ended up installing Microsoft's MediaCreationTool and creating a FAT32-based bootable USB drive.
  2. Using this drive; I was once able to boot into the Windows 10 Installation. Since I was not able to quickly obtain a product key and thought I needed one for the installation, I canceled the installation at this point.
  3. After cancelling the installation, the Windows partition stopped showing up as a startup disk!
  4. I restarted the Boot Camp procedure, erasing- and re-creating the Bootcamp-partition.
  5. The USB drive stopped being recognised; I again get the above error message No bootable device -- insert boot disk and press any key. In macOS the USB drive shows up without any problem.

I did a few more attempts (each time erasing and creating the bootcamp partition; trying to create another USB tool), but always with the same result.

Any help in getting this to run is appreciated. If possible, I'd like to avoid updating to mac OS Catalina.

  • I can't really help with the overall issue - but one thing is, you can install Win10 without having to enter a product key & it will let you sort it out later, once it's all up & running. – Tetsujin Apr 17 at 8:34
  • 1
    @Tetsujin Thanks; I clarified that I am in the meantime aware of this fact. Unfortunately I don't get to this point anymore. – moktor Apr 17 at 8:39
2

The Boot Camp Assistant works under very strict conditions. Failure occurs when any one of the conditions is ignored. In your case, the condition was using Sierra. Apple expects you to install the latest version of macOS available for your model Mac.

The firmware needed to allow booting from ExFAT formatted media is installed when upgrading to High Sierra. Since you are using Sierra, your Mac probably has not had this firmware upgrade. The default Windows 10 ISO file, downloaded from Microsoft when running macOS, contains the file install.wim, which is to large to store in a FAT32 formatted volume. However, the Windows 10 ISO or USB flash drive, created using the media creation tool, substitutes a install.esd file for the install.wim file. Basically, .esd files use a better compression algorithm than .wim files. The result is the install.esd file can be stored on FAT32 formatted volumes. You could use a ExFAT (or maybe FAT32) formatted flash drive to transfer the Windows 10 ISO, created using the media create tool, from machine running Windows to your Mac running Sierra.

Note: I do not know, if the install.wim file contains the same data as the install.esd file. There may very well be extra files in the install.wim version that Macs need that does not exist in the install.esd version.

Your model Mac is designed to BIOS boot Windows 7 and UEFI boot Windows 10. When BIOS booting Windows, the installation drive needs to be hybrid partitioned. The Boot Camp Assistant automatically determines, if hybrid partitioning is needed for a Windows installation by inspecting the Windows USB flash drive. Of course, the assumption is the files on the flash drive were created by the Boot Camp Assistant. From the way you worded your question, apparently the only files on the flash drive were put there by the Microsoft media creation tool.

The GUI Windows installer will only install for BIOS booting when the installation drive is hybrid partitioned, otherwise Windows will be installed for UEFI booting. Your model Mac should install Windows 10 to UEFI boot, primarily because the Windows Support Software is designed for a UEFI booting Windows 10.

Note: The message No bootable device -- insert boot disk and press any key is a indication the firmware is trying to BIOS boot the Windows installation media. The media should be UEFI booting.

Options:

  • Try using the ISO file which can be created using the media create tool.
  • Upgrade to a newer version of macOS.
  • Install Windows using the macOS and Windows CLI. This option requires many steps which were omitted from this answer.
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .