0

I have an external hard drive with some backup files in it. Today I moved a folder with some Flac files and one jpg from the external HD to my iMac HD. When I tried and open the Flac files on the Mac, VLC showed them as "zero seconds", whereas Preview didn't open the jpg. Both software returned no error message.

I tried opening a bunch of files currently on the external HD (text, pdf, mp3,...) with different software. Same results. Names, extensions, and sizes are correct for all of them, but it seems like they are missing "something" for them to be recognized for what they are (metadata, maybe?)

I tried using SOS (disk utility), it found some minor problems, repair them, but the end result is the same. I even tried a Windows PC with a third party software: the same story, the files just won't open regardless of the software I use.

I finally tried with a data recovery software, but it only found deleted files, I couldn't "recover" files that weren't deleted.

I could probably try and create an image of the disk, but it's 2TB and I don't have enough space, and anyway, will it work?

Does anybody have an idea of what is going on?

1

Your files are corrupted.

If you can use macOS or Windows to open these files, you’ve reduced the points of failure that would have caused it. You’re down to the USB enclosure or the drive itself.

Recovery software won’t work because it looks for “orphaned” blocks of data. When you have a file, nothing is orphaned. The software has no idea that the contents are a jumbled mess, it just knows the file is complete.

For now, test out your drive. Write files to it. Then disconnect it, reconnect it and try to read those files back. If it fails, your enclosure and/or drive is failing.

1
  • Tried. Both Windows and Mac. No problem moving, opening, deleting, etc. new files. Perhaps it's worth mentioning that the hard disk is very slow. I suspect it's a sort of SD card put inside a mini ssd-looking enclosure. The write speed in particular is abysmal. – Giorgio Leoni Apr 16 '20 at 16:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .