2

My workplace uses Cisco AnyConnect VPN (but I have seen same problems with other VPNs as well, eg. here) and it seems to break AirDrop, Sidecar and similar Apple's local network services.

While I am connected to VPN on my macbook, I cannot AirDrop files to my macbook, and Sidecar doesn't start (shows a timeout error after a while). When I disconnect, everything works again.

Is there a know set of things (ports, port ranges, network broadcasts?) I could change or enable in VPN settings so that the 'Apple stuff' would still be routed to a local network at home? It seems that now everything gets routed into work VPN.

Thanks! I googled, but so far found only threads asking for help, with no solution.

2

I just spent couple of hours trying to figure out how to solve this issue, and the solution was quite simple. The problem with AnyConnect and cisco VPN is that it forces whole traffic to go through it, which includes local network (thus making other LAN hosts inaccessible). There seems to no to little config options in AnyConnect itself. Plus using USB seems to be working up until VPN connection is made.

However, I found thanks to some forums that one can use openconnect to connect to PPTP VPN instead.

brew install openconnect

and then

sudo openconnect --user your_vpn_user --protocol=anyconnect vpn.server.com establishes equivalent connection and doesn't interfere with LAN addresses! Plus it doesn't even need any cumbersome and slow GUI to do this. So it is a win win.

P.S. I was close to turn my spare Raspberry Pi into a WiFi access point with VPN tunnel there and properly set up routing. Saved myself more problems.

1

I was having the same issue whenever I connected my MacBook and iPhone via Mullvad VPN. I do not have VPN at router but on individual devices, so VPN broke my iCloud copy/paste and airdrop. It may be because they were not sharing same wifi network anymore, as in, they had two different data tunnels, and the only solution I found was to deploy VPN at router or turn off VPN.

I dig Mullvad VPN Mac app preferences, and found that there is an option to enable "Local network sharing" that allows local network access to connected devices. I turned it on and voila, I had my airdrop back. I believe that major VPN providers' Mac app has this function, and if you toggle this function, you can get your problem solved.

Screenshot of Mullvad Mac app setting

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .