0

Since macOS update 10.15.4, I have been having a problem with Safari.

When I open Safari on one desktop/Space and switch to another one, after a short delay of approximately a second Safari steals focus and swaps Spaces back to the one where it is open. No matter how many times I change the space I'm using, it keeps reverting back to the one where safari is open.

Any ideas on what might be causing this, or how I can fix it? I use Spaces a lot for my workflow and this basically renders them unusable while safari is open.

1

I am having the exact same issue. Safari kept stealing focus no matter which fullscreen app I would move to. It only does this when moving to a fullscreen app. I found a workaround that keeps it from switching completely away from the fullscreen apps.

I unchecked "When switching to an application, switch to a Space with open windows for the application" in Mission Control. And this stops it from moving back to wherever Safari is open across spaces or screens (running with an external monitor).

This doesn't fix the problem completely as Safari is still technically stealing focus as apps will basically twitch and the Touchbar will switch to Safari displaying the "New Window" "New Private Window" buttons. When switching to Google Chrome, the top part of the app will drop slightly as if the menu bar was being selected and then you have to click into Chrome again to get the focus back to chrome.

| improve this answer | |
  • 1
    I think I figured out the issue. I closed "OnScreen Control" which is an app for my LG monitor. It seems to have fixed the issue. – kcappy Apr 28 at 23:29
  • Spot on - that's what fixed it for me in the end. I've accepted your answer as you were the first to come up with the right solution - might be worth editing your answer to have the actual solution in the main answer? – merithayan Jun 8 at 17:54
  • this was it for me as welll BTW, you don't need to close it, you need to not configure default app to default windows. – djsly Sep 17 at 18:10
1

As @kcappy suggested, if you use "OnScreen Control" by LG then close it to solve this issue.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .