0

In short - I thought my earlier Python 3 enquiry would solve my problem with Youtube-dl but it didn't. I am working through a reddit enquiry I put in a couple of weeks ago and am now a bit stumped:

https://www.reddit.com/r/youtubedl/comments/frq8kr/am_getting_errors_when_grabbing_things_from/

For clarification I'm just looking to grab some mixes whilst working from home during lockdown.

My mac is an aging 2012 iMac, am running 10.12.6, XCode is 8.2, Python have 2.7 that it was installed with, 2.7.16 and 3.7 something.

Youtube-dl is only appearing to pick up 2.7 however;

e.g. youtube-dl --verbose - returns the following;

[debug] System config: []

[debug] User config: [u'-o', u'~/Downloads/%(title)s-%(id)s.%(ext)s']

[debug] Custom config: []

[debug] Command-line args: [u'--verbose']

[debug] Encodings: locale UTF-8, fs utf-8, out UTF-8, pref UTF-8

[debug] youtube-dl version 2020.01.01

[debug] Python version 2.7.10 (CPython) - Darwin-16.7.0-x86_64-i386-64bit

[debug] exe versions: avconv 11.4, avprobe 11.4

[debug] Proxy map: {}

Usage: youtube-dl [OPTIONS] URL [URL...]

The error I'm returning is the following;

ERROR: Unable to download JSON metadata: (caused by URLError(SSLError(1, u'[SSL: TLSV1_ALERT_PROTOCOL_VERSION] tlsv1 alert protocol version (_ssl.c:590)'),))

The thought in the thread was people were thinking it was the OpenSSL libraries that needed updating. I'd hoped downloading a newer version of Python would have solved that but it didn't appear to.

Am a little stumped now and outside of my level of expertise which is frankly limited at the best of times.

I would be grateful for any advice or suggestions.

1

I ran into the same error (2010 MacBook Pro) and updating to Python 2.7.18 seemed to fix the issue. You can update to 2.7.18 here. I used the macOs 64-bit Installer, but feel free to install whichever way is easiest for you.

Screenshot of running youtube-dl post update: enter image description here

Hope this helps!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .