I'm trying to give Accessibility permission to VMWare Fusion. It shows up in the System Preferences but clicking the checkbox does nothing.

enter image description here

This is Fusion 11.5.3 which is specifically targeting Catalina.

How can I grant it Accessability permissions?

  • 1
    In General, did you approve the kernel extension first? – bmike Apr 12 '20 at 16:01
  • Firstly, have you simply tried rebooting? If that doesn't work, uninstall and reinstall the program. – KidACrimson Apr 12 '20 at 16:26

You are doing the correct step. Unless VMWare has an uninstall / reinstall or way to clear that, you might need to start over with the database that tracks that entitlement.

  1. Make a new admin user in system preferences and log out of the current user.
  2. Log out of the current user and log in - try. Also consider disabling automatic log in and restart - then use the new account.
  3. Make sure SIP is enabled: csrutil status should show enabled
  4. Be sure you allowed the kernel extension for VMware Fusion to run. You have to click allow in the general security pane before you can go to the privacy pane to allow Accessibility and other more granular entitlements. Uninstalling and reinstalling VMWare Fusion should prompt you for this kernel approval before you have to accept the EULA and enter a license but after you approve the installer to run an admin script.

To wipe all the settings for that app, you need it's bundle identifier:

How do I reset Screen Recording permission on macOS Catalina?

In your case, the reset would be for the VMware Fusion app or processes. To get that, you can open the command line in terminal app and type mdls -name kMDItemCFBundleIdentifier and then drag the VMWare fusion app into the window and press return.

tccutil reset All com.vmware.fusion
  • 1
    I tried the tccutil reset first and it seems to have worked. I was able to check the box in System Preferences. – gman Apr 13 '20 at 5:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .