1

Went to use my MacBook two days after switching on with no issue. When I went to boot it was completely dead. When I went to charge it, there was no light.

I left it on the charger for 20 mins and returned to a solid green light. I did an SMC reset which set it back to amber. The MacBook booted and worked fine for around 4 mins. The battery was registered at 32% (think it’s only around 420 cycle). It suddenly died, and returned to a solid green light.

I left it to charge where I noticed it flick between amber and green, but then was permanently green. Still no boot so took the charger off and went to put it back on and it’s been dead since!

Any help would be appreciated! I have the parts ordered that’s needed to open and try restart the battery.

11
  • What’s the question? – Allan Apr 11 '20 at 16:20
  • Any idea what the issue may be? There’s no sign of life from it. Would it be worth replacing the dc in board adapter before going down the road of logic board malfunction – Tantrim Apr 11 '20 at 16:24
  • No water damage either – Tantrim Apr 11 '20 at 16:24
  • It could be anything, but I doubt it’s a dc in board issue. If your battery is charged, you can boot with a dc-in board. It could be as simple as a bad power button, but likely it’s a logic board issue. – Allan Apr 11 '20 at 16:28
  • I don’t think the solid green light was showing a fully charged battery, I think it was more of an issue to be honest. – Tantrim Apr 11 '20 at 16:31
1

this sounds like a Hardware Issue definitely. I have the same A1502 model. I have never seen any Mac do this but if you can connect the MacBook Pro to its charger then startup, you should press "D" while its starting. This will allow it to check itself for issues. If you are convinced that its a software issue, you can try booting up from macOS Recovery and reinstalling macOS. Good luck!

8
  • Not sure if it helps, but when I have the power cable plugged in, and hold the power button, I can hear a ticking sound when I press my ear against the bottom of case where the charger port is located – Tantrim Apr 11 '20 at 18:54
  • That could mean that there is a lot of dust down there. Can you see the Apple logo when you try to startup with the power cable plugged in? – Todd Apr 11 '20 at 21:50
  • To be honest Todd it sounds more staticky! Nope, trackpad also doesn’t come active. Still going to try a new (used) dc in board. – Tantrim Apr 11 '20 at 23:00
  • So no Apple logo? If it is staticky, then that’s definitely not good. So we’re you able to do the power on self-test? – Todd Apr 12 '20 at 2:16
  • That “ticking” noise is most likely “attempted” fan spin. It’s the only mechanical component on the logic board. The fan will turn on (normally), but it may be intermittent if there’s an issue with the logic board. – Allan Apr 12 '20 at 11:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .