5

Over the past few months (possibly since installing iOS 13.2 back in October 2019 but I'm not sure) my iPhone has been listing my home Apple TVs as audio options when on phone calls.

Normally when on a call you see a "speaker" button and tapping that once activates speakerphone, but for me the button is labeled "audio":

speaker button replaced with audio button

and tapping it brings up this menu:

list of audio options including apple tvs

If I choose any of the Apple TV options, the menu goes away and the audio button changes to a button with a Bluetooth icon:

audio button has a bluetooth icon

My concern is that I usually want to activate speakerphone on every call, and would never want to route call audio through an Apple TV, and now something that used to take one tap now takes two, adding additional complexity to the beginning of each call.

How do I make it so that the Apple TVs do not show up as audio options?

Some notes and troubleshooting steps taken:

  • The implied result of routing the call audio through an Apple TV doesn't actually work, even if I wanted to do that. Once I've chosen one of the Apple TVs and the audio button changes to the one with the Bluetooth symbol, call audio goes silent for about 5-10 seconds (audio does not come out of the iPhone nor the TV connected to the Apple TV). After 5-10 seconds of silence the call audio is restored to the iPhone's ear speaker and the Bluetooth audio button changes back to the original audio button. If I tap audio again it shows that audio is coming from the iPhone, not the Apple TV. This behaves the same way whether an Apple TV is sleeping or not.

  • I'm currently running iOS 13.4.1 and this behavior persists.

  • The Apple TVs show up whether they are awake or sleeping.

  • Apple TVs do not show up if they are powered off (power cable unplugged). However, after unplugging one, it still shows up in the list for 1-2 minutes, which implied there is some kind of caching going on, rather than immediate/real-time discovery. Also, powering off my Apple TVs would not be an accepted solution because I do not want to have to constantly be plugging in and unplugging my Apple TVs when I want to use them.

  • The Apple TVs still show up if I press the Bluetooth button in Control Center to disconnect from Bluetooth devices or if I turn off Bluetooth completely. Furthermore, no Apple TVs show up in the devices list in Settings → Bluetooth.

  • My iPhone does not appear as a Bluetooth device in Settings → Remotes and Devices → Bluetooth on the Apple TV, and there does not appear to be a way to disable Bluetooth in tvOS, although I wouldn't want to do that because I often use AirPlay which relies on Bluetooth.

  • The Apple TVs do not show up when I disconnect from my home Wi-fi, however I vaguely remember one of them showing up one time a few months ago while I was on a call at work (on a completely different Wi-fi network nowhere near my home), implying that it's somehow connected through iCloud, although I could be mistaken.

  • An Apple TV will show up even if I have signed out of iCloud on the Apple TV in Settings → Users and Accounts → iCloud.

  • An Apple TV will show up even if Home Sharing is turned off on the Apple TV in Settings → Users and Accounts → Home Sharing.

  • I'd previously had an issue where Macs on my Wi-fi were showing up in the audio list just like these Apple TVs are now, and I posted a working/upvoted (but not yet accepted) solution in this post. However, that solution does not apply in this case because tvOS devices do not show up in Settings → Phone → Calls on Other Devices list (only macOS and iOS devices).

  • The Apple TVs still show up if I go to Settings → General → AirPlay & Handoff → Automatically AirPlay to TVs on my iPhone and set that to Never.

  • The Apple TVs still show up if I go to Settings → General → AirPlay & Handoff on my iPhone and switch off Handoff.

  • An Apple TV will still show up if I go to Settings → AirPlay and HomeKit on my Apple TV and turn off AirPlay.

  • My iPhone showed up in the list of devices in Settings → Remotes and Devices → Remote App and Devices on each Apple TV but selecting "Unpair Device" for one of them did not resolve the issue.

  • Nothing shows up in Settings → General → Privacy → Bluetooth on the Apple TV.

  • I have never used HomeKit and there are no Apple TVs (or any other devices) listed in the Home app on my iPhone.

I've exhausted all of my potential solutions at this point. Any ideas?

3
  • It's a great question, but I'm fairly certain that the answer is "you can't change it". Except for maybe using a different Apple ID on all your other devices, which is silly. I wish there was an option to remember your last setting, or always use speakerphone if you answer while the phone is laying flat, etc. Sigh, someday...
    – jimtut
    Apr 12 '20 at 20:32
  • Agreed, the reason why I'd been putting off posting this here for a while is because I'd assumed that it's just something you can't change, but I finally posted because I've been on more calls since starting remote work last month and it's bothering me more often now. I also found a workaround in this post on the Apple Support forums which works if you want to always use speakerphone. It's not a solution to this problem, but it might work for some people.
    – Employee
    Apr 14 '20 at 19:46
  • Yeah, I've seen that before, but it's really hard-coded to speakerphone, even when in a car and you have Bluetooth or CarPlay available. :-(
    – jimtut
    Apr 15 '20 at 15:32
1

I’ve been living with this annoying issue for a year or so now and I am delighted to say it appears the most recent iOS update, version 13.5.1, has fixed this issue!

I no longer see AppleTV as an option when toggling speakerphone. It simply puts the caller on speakerphone.

1
  • Upon seeing your answer I checked while on iOS 13.5 and indeed, the behavior was no longer occurring. Updated to 13.5.1 and it's still not occurring. Now let's hope that they actually meant to do that and it won't get reverted in a future update.
    – Employee
    Jun 19 '20 at 1:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .